summaryrefslogtreecommitdiff
path: root/openwrt/package/mini_httpd/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-02-04 21:55:53 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-02-04 21:55:53 +0000
commit8c05e7e7761215de8581ae3b8e8bf0932f1b1c76 (patch)
treee0b4d169bdbc15cd31158851dff11612ecc6341e /openwrt/package/mini_httpd/Makefile
parentb436e07724236238d9ddb7c3b384d22131612c65 (diff)
downloadmtk-20170518-8c05e7e7761215de8581ae3b8e8bf0932f1b1c76.zip
mtk-20170518-8c05e7e7761215de8581ae3b8e8bf0932f1b1c76.tar.gz
mtk-20170518-8c05e7e7761215de8581ae3b8e8bf0932f1b1c76.tar.bz2
Added mini-http-htpasswd package, closes request #251
SVN-Revision: 3129
Diffstat (limited to 'openwrt/package/mini_httpd/Makefile')
-rw-r--r--openwrt/package/mini_httpd/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/openwrt/package/mini_httpd/Makefile b/openwrt/package/mini_httpd/Makefile
index 053ac91..da976ef 100644
--- a/openwrt/package/mini_httpd/Makefile
+++ b/openwrt/package/mini_httpd/Makefile
@@ -16,6 +16,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/mini_httpd-$(PKG_VERSION)
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,MINI_HTTPD,mini-httpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,MINI_HTTPD_HTPASSWD,mini-httpd-htpasswd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,MINI_HTTPD_MATRIXSSL,mini-httpd-matrixssl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,MINI_HTTPD_OPENSSL,mini-httpd-openssl,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -71,6 +72,12 @@ $(IPKG_MINI_HTTPD):
$(RSTRIP) $(IDIR_MINI_HTTPD)
$(IPKG_BUILD) $(IDIR_MINI_HTTPD) $(PACKAGE_DIR)
+$(IPKG_MINI_HTTPD_HTPASSWD):
+ install -d -m0755 $(IDIR_MINI_HTTPD_HTPASSWD)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/htpasswd $(IDIR_MINI_HTTPD_HTPASSWD)/usr/sbin/
+ $(RSTRIP) $(IDIR_MINI_HTTPD_HTPASSWD)
+ $(IPKG_BUILD) $(IDIR_MINI_HTTPD_HTPASSWD) $(PACKAGE_DIR)
+
$(IPKG_MINI_HTTPD_MATRIXSSL):
install -d -m0755 $(IDIR_MINI_HTTPD_MATRIXSSL)/etc
install -m0644 ./files/mini_httpd-ssl.conf $(IDIR_MINI_HTTPD_MATRIXSSL)/etc/mini_httpd.conf