summaryrefslogtreecommitdiff
path: root/openwrt/package/mini_httpd/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-19 00:16:27 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-19 00:16:27 +0000
commit9056ac5ca0fadfa778ae21013ff3a7bf4010e383 (patch)
tree7b91c79d3e371a427cdb33e01139c280aafcde9a /openwrt/package/mini_httpd/patches
parent5824225005e76a5d63e0002bf8895104631e494c (diff)
downloadmtk-20170518-9056ac5ca0fadfa778ae21013ff3a7bf4010e383.zip
mtk-20170518-9056ac5ca0fadfa778ae21013ff3a7bf4010e383.tar.gz
mtk-20170518-9056ac5ca0fadfa778ae21013ff3a7bf4010e383.tar.bz2
add a patch to provide a descent PATH to cgi, split in 3 packages (w/o ssl, w/ matrixssl & w/ openssl), add a restart command to init-script.
SVN-Revision: 2174
Diffstat (limited to 'openwrt/package/mini_httpd/patches')
-rw-r--r--openwrt/package/mini_httpd/patches/001-cgi_path.patch16
-rw-r--r--openwrt/package/mini_httpd/patches/500-matrixssl.patch10
2 files changed, 21 insertions, 5 deletions
diff --git a/openwrt/package/mini_httpd/patches/001-cgi_path.patch b/openwrt/package/mini_httpd/patches/001-cgi_path.patch
new file mode 100644
index 0000000..c847d94
--- /dev/null
+++ b/openwrt/package/mini_httpd/patches/001-cgi_path.patch
@@ -0,0 +1,16 @@
+diff -ruN mini_httpd-1.19-old/mini_httpd.c mini_httpd-1.19-new/mini_httpd.c
+--- mini_httpd-1.19-old/mini_httpd.c 2005-10-19 01:11:24.000000000 +0200
++++ mini_httpd-1.19-new/mini_httpd.c 2005-10-19 01:13:05.000000000 +0200
+@@ -138,10 +138,10 @@
+ #define CGI_NICE 10
+ #endif /* CGI_NICE */
+ #ifndef CGI_PATH
+-#define CGI_PATH "/usr/local/bin:/usr/ucb:/bin:/usr/bin"
++#define CGI_PATH "/usr/bin:/bin:/usr/sbin:/sbin"
+ #endif /* CGI_PATH */
+ #ifndef CGI_LD_LIBRARY_PATH
+-#define CGI_LD_LIBRARY_PATH "/usr/local/lib:/usr/lib"
++#define CGI_LD_LIBRARY_PATH "/usr/lib:/lib"
+ #endif /* CGI_LD_LIBRARY_PATH */
+ #ifndef AUTH_FILE
+ #define AUTH_FILE ".htpasswd"
diff --git a/openwrt/package/mini_httpd/patches/500-matrixssl.patch b/openwrt/package/mini_httpd/patches/500-matrixssl.patch
index e2d83af..0ab8d68 100644
--- a/openwrt/package/mini_httpd/patches/500-matrixssl.patch
+++ b/openwrt/package/mini_httpd/patches/500-matrixssl.patch
@@ -14,11 +14,11 @@ diff -ruN mini_httpd-1.19-orig/Makefile mini_httpd-1.19-3/Makefile
+#SSL_OBJS =
+
+# MatrixSSL
-+SSL_TREE =
-+SSL_DEFS = -DUSE_SSL -DHAVE_MATRIXSSL
-+SSL_INC =
-+SSL_LIBS = -lmatrixssl
-+SSL_OBJS = matrixssl_helper.o
++#SSL_TREE =
++#SSL_DEFS = -DUSE_SSL -DHAVE_MATRIXSSL
++#SSL_INC =
++#SSL_LIBS = -lmatrixssl
++#SSL_OBJS = matrixssl_helper.o
-BINDIR = /usr/local/sbin