summaryrefslogtreecommitdiff
path: root/openwrt/package/mtd
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-04 00:13:34 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-04 00:13:34 +0000
commite3a5f7bb49f04dd8bd2804c35ff6e22cdb88f7c8 (patch)
tree543acd1c3285a8be6bd33bf3dac34c4033295f95 /openwrt/package/mtd
parent916d5c6b146856dd67488e4cd239fccfc280f0c8 (diff)
downloadmtk-20170518-e3a5f7bb49f04dd8bd2804c35ff6e22cdb88f7c8.zip
mtk-20170518-e3a5f7bb49f04dd8bd2804c35ff6e22cdb88f7c8.tar.gz
mtk-20170518-e3a5f7bb49f04dd8bd2804c35ff6e22cdb88f7c8.tar.bz2
revert my changes. didn't work
SVN-Revision: 1842
Diffstat (limited to 'openwrt/package/mtd')
-rw-r--r--openwrt/package/mtd/Makefile6
-rw-r--r--openwrt/package/mtd/mtd.c4
2 files changed, 1 insertions, 9 deletions
diff --git a/openwrt/package/mtd/Makefile b/openwrt/package/mtd/Makefile
index b2090a6..bfbb301 100644
--- a/openwrt/package/mtd/Makefile
+++ b/openwrt/package/mtd/Makefile
@@ -7,10 +7,6 @@ PKG_RELEASE := 1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-ifeq ($(LINUX_VERSION),2.4.30)
-VER=-DLINUX_24
-endif
-
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
@@ -20,7 +16,7 @@ $(PKG_BUILD_DIR)/.prepared:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(TARGET_CC) -I$(LINUX_DIR)/include $(VER) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+ $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
touch $@
$(IPKG_MTD):
diff --git a/openwrt/package/mtd/mtd.c b/openwrt/package/mtd/mtd.c
index e559864..69ef064 100644
--- a/openwrt/package/mtd/mtd.c
+++ b/openwrt/package/mtd/mtd.c
@@ -40,11 +40,7 @@
#include <sys/reboot.h>
#include <string.h>
-#ifdef LINUX_24
#include <linux/mtd/mtd.h>
-#else
-#include <mtd/mtd-user.h>
-#endif
#define TRX_MAGIC 0x30524448 /* "HDR0" */
#define BUFSIZE (10 * 1024)