summaryrefslogtreecommitdiff
path: root/openwrt/package/ncurses/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-24 00:46:13 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-24 00:46:13 +0000
commitf97bff36e4d5135387227d2305741a00a7cef71e (patch)
treec1ac2f061b46742bb65e5439272b91d13b6b18b6 /openwrt/package/ncurses/Makefile
parent6d555f7cc6fb12387a5fff090f0e12e6c4993c1d (diff)
downloadmtk-20170518-f97bff36e4d5135387227d2305741a00a7cef71e.zip
mtk-20170518-f97bff36e4d5135387227d2305741a00a7cef71e.tar.gz
mtk-20170518-f97bff36e4d5135387227d2305741a00a7cef71e.tar.bz2
Fix typos in unstall-dev
SVN-Revision: 1040
Diffstat (limited to 'openwrt/package/ncurses/Makefile')
-rw-r--r--openwrt/package/ncurses/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/openwrt/package/ncurses/Makefile b/openwrt/package/ncurses/Makefile
index 1bab2d9..5139a5a 100644
--- a/openwrt/package/ncurses/Makefile
+++ b/openwrt/package/ncurses/Makefile
@@ -103,18 +103,19 @@ $(STAGING_DIR)/usr/lib/libncurses.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/lib
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libcurses.so $(STAGING_DIR)/usr/lib/
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel}.{a,so*} $(STAGING_DIR)/usr/lib/
+ touch $@
install-dev: $(STAGING_DIR)/usr/lib/libncurses.so
uninstall-dev:
rm -rf \
- $(PKG_INSTALL_DIR)/usr/include/curses.h \
- $(PKG_INSTALL_DIR)/usr/include/{ncurses,panel}.h \
- $(PKG_INSTALL_DIR)/usr/include/panel.h \
- $(PKG_INSTALL_DIR)/usr/include/term{,cap}.h \
- $(PKG_INSTALL_DIR)/usr/include/unctrl.h \
- $(PKG_INSTALL_DIR)/usr/lib/libcurses.so \
- $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel}.{a,so*} \
+ $(STAGING_DIR)/usr/include/curses.h \
+ $(STAGING_DIR)/usr/include/{ncurses,panel}.h \
+ $(STAGING_DIR)/usr/include/panel.h \
+ $(STAGING_DIR)/usr/include/term{,cap}.h \
+ $(STAGING_DIR)/usr/include/unctrl.h \
+ $(STAGING_DIR)/usr/lib/libcurses.so \
+ $(STAGING_DIR)/usr/lib/lib{ncurses,panel}.{a,so*} \
compile: install-dev
clean: uninstall-dev