summaryrefslogtreecommitdiff
path: root/openwrt/package/ncurses
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
commitb7d92815a6aaefcf2aa6240346445530473e9c1e (patch)
tree66a9a28ea0c69b059939becc0f335bc8ec1d5437 /openwrt/package/ncurses
parent322b84237cee9e9adb88d32af8f20f384066866e (diff)
downloadmtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.zip
mtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.tar.gz
mtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.tar.bz2
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
SVN-Revision: 577
Diffstat (limited to 'openwrt/package/ncurses')
-rw-r--r--openwrt/package/ncurses/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/package/ncurses/Makefile b/openwrt/package/ncurses/Makefile
index 3835af6..3d73e77 100644
--- a/openwrt/package/ncurses/Makefile
+++ b/openwrt/package/ncurses/Makefile
@@ -20,6 +20,8 @@ PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
PKG_IPK := $(PACKAGE_DIR)/lib$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+.NOTPARALLEL:
+
$(DL_DIR)/$(PKG_SOURCE_FILE):
mkdir -p $(DL_DIR)
$(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) $(PKG_MD5SUM) $(PKG_SOURCE_SITE)
@@ -35,7 +37,7 @@ $(PKG_IPK): $(PKG_BUILD_DIR)/ipkg/rules
cd $(PKG_BUILD_DIR); \
TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
INSTALL_DIR="$(STAGING_DIR)" \
- ./ipkg/rules package
+ $(MAKE) -j1 -f ./ipkg/rules package
$(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list: $(PKG_IPK)
$(IPKG) install $(PKG_IPK)