summaryrefslogtreecommitdiff
path: root/openwrt/package/net-snmp/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-06-08 19:54:05 +0000
committerNicolas Thill <nico@openwrt.org>2005-06-08 19:54:05 +0000
commit45c6c3628579e4a00c1104413f3364108137f571 (patch)
tree72da19c6e46497fac205668525cec2563d9cf290 /openwrt/package/net-snmp/Makefile
parent417b433766a3236138b965d2820f3a0495c5e182 (diff)
downloadmtk-20170518-45c6c3628579e4a00c1104413f3364108137f571.zip
mtk-20170518-45c6c3628579e4a00c1104413f3364108137f571.tar.gz
mtk-20170518-45c6c3628579e4a00c1104413f3364108137f571.tar.bz2
Always use -R flag with cp (to preserve symlinks)
SVN-Revision: 1175
Diffstat (limited to 'openwrt/package/net-snmp/Makefile')
-rw-r--r--openwrt/package/net-snmp/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/net-snmp/Makefile b/openwrt/package/net-snmp/Makefile
index ba88748..166d9d3 100644
--- a/openwrt/package/net-snmp/Makefile
+++ b/openwrt/package/net-snmp/Makefile
@@ -163,11 +163,11 @@ $(IPKG_SNMP_UTILS):
$(STAGING_DIR)/usr/lib/libnetsnmp.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/bin
- cp -fp $(PKG_INSTALL_DIR)/usr/bin/net-snmp-config $(STAGING_DIR)/usr/bin/
+ cp -fpR $(PKG_INSTALL_DIR)/usr/bin/net-snmp-config $(STAGING_DIR)/usr/bin/
mkdir -p $(STAGING_DIR)/usr/include
cp -fpR $(PKG_INSTALL_DIR)/usr/include/net-snmp $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib
- cp -fp $(PKG_INSTALL_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*} $(STAGING_DIR)/usr/lib/
+ cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libnetsnmp{,agent,helpers,mibs}.{a,so*} $(STAGING_DIR)/usr/lib/
touch $@
install-dev: $(STAGING_DIR)/usr/lib/libnetsnmp.so