summaryrefslogtreecommitdiff
path: root/openwrt/package/nmap/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-06-12 20:16:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-06-12 20:16:28 +0000
commitfa69fade3bbd9bca3791c457234968c8174a5163 (patch)
treee2dc23da6a4f0f3ba8a52a62aae244e206f52505 /openwrt/package/nmap/Makefile
parent93341477c50d7fa79e09d50f8b67b26c08277277 (diff)
downloadmtk-20170518-fa69fade3bbd9bca3791c457234968c8174a5163.zip
mtk-20170518-fa69fade3bbd9bca3791c457234968c8174a5163.tar.gz
mtk-20170518-fa69fade3bbd9bca3791c457234968c8174a5163.tar.bz2
add --without-nmapfe to nmap configure and add mostlyclean target for rebuild
SVN-Revision: 1221
Diffstat (limited to 'openwrt/package/nmap/Makefile')
-rw-r--r--openwrt/package/nmap/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/openwrt/package/nmap/Makefile b/openwrt/package/nmap/Makefile
index 6e685b4..8c01084 100644
--- a/openwrt/package/nmap/Makefile
+++ b/openwrt/package/nmap/Makefile
@@ -48,6 +48,7 @@ $(PKG_BUILD_DIR)/.configured:
$(DISABLE_LARGEFILE) \
$(DISABLE_NLS) \
--without-openssl \
+ --without-nmapfe \
--with-libpcap="$(STAGING_DIR)/usr" \
--with-libpcre="$(STAGING_DIR)/usr" \
);
@@ -71,3 +72,7 @@ $(IPKG_NMAP):
cp -fpR $(PKG_INSTALL_DIR)/usr/bin/nmap $(IDIR_NMAP)/usr/bin/
$(RSTRIP) $(IDIR_NMAP)
$(IPKG_BUILD) $(IDIR_NMAP) $(PACKAGE_DIR)
+
+mostlyclean:
+ $(MAKE) -C $(PKG_BUILD_DIR) clean
+ rm $(PKG_BUILD_DIR)/.built