summaryrefslogtreecommitdiff
path: root/openwrt/package/nmap
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-10-23 01:29:01 +0000
committerNicolas Thill <nico@openwrt.org>2005-10-23 01:29:01 +0000
commit650cb6dc83eb1cc7d429ea9e557ebc857f5c9387 (patch)
tree4a9c268cf4e8d0b68f5ac5fd9bb5cf2489872dd3 /openwrt/package/nmap
parent48bd032248fdc8781442e370b384070b1767a7ef (diff)
downloadmtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.zip
mtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.tar.gz
mtk-20170518-650cb6dc83eb1cc7d429ea9e557ebc857f5c9387.tar.bz2
build c++ sources without rtti
SVN-Revision: 2271
Diffstat (limited to 'openwrt/package/nmap')
-rw-r--r--openwrt/package/nmap/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/openwrt/package/nmap/Makefile b/openwrt/package/nmap/Makefile
index 2cded7e..1aa8bed 100644
--- a/openwrt/package/nmap/Makefile
+++ b/openwrt/package/nmap/Makefile
@@ -23,10 +23,10 @@ $(PKG_BUILD_DIR)/.configured:
$(TARGET_CONFIGURE_OPTS) \
libpcapdir="$(STAGING_DIR)/usr/lib" \
CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -nostdinc++" \
+ CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- LIBS="-nodefaultlibs -luClibc++ -lc -lm" \
+ LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ LIBS="-luClibc++ -lc -lm" \
ac_cv_prog_CXX="$(TARGET_CXX)" \
./configure \
--target=$(GNU_TARGET_NAME) \