summaryrefslogtreecommitdiff
path: root/openwrt/package/nocatsplash/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-04 13:14:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-04 13:14:29 +0000
commit5135ae2b7524dd340fd2fd32375e3bebb25892c4 (patch)
tree78622815e415ecbe61b820e255decc86e11d40e0 /openwrt/package/nocatsplash/Makefile
parentb1b01bcc6c91e07300385e08fe55aef593cb884a (diff)
downloadmtk-20170518-5135ae2b7524dd340fd2fd32375e3bebb25892c4.zip
mtk-20170518-5135ae2b7524dd340fd2fd32375e3bebb25892c4.tar.gz
mtk-20170518-5135ae2b7524dd340fd2fd32375e3bebb25892c4.tar.bz2
fix include path for glib in nocatsplash
SVN-Revision: 555
Diffstat (limited to 'openwrt/package/nocatsplash/Makefile')
-rw-r--r--openwrt/package/nocatsplash/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/openwrt/package/nocatsplash/Makefile b/openwrt/package/nocatsplash/Makefile
index d5d6b36..af79e67 100644
--- a/openwrt/package/nocatsplash/Makefile
+++ b/openwrt/package/nocatsplash/Makefile
@@ -44,10 +44,13 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
);
touch $(PKG_BUILD_DIR)/.configured
+GLIB_CFLAGS :=-I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include
+
$(PKG_BUILD_DIR)/src/splashd: $(PKG_BUILD_DIR)/.configured
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) \
- GLIB_CFLAGS="-I$(STAGING_DIR)/usr/include/glib-1.2 -I$(STAGING_DIR)/usr/lib/glib/include" \
+ GLIB_CFLAGS="$(GLIB_CFLAGS)" \
+ AM_CFLAGS="$(TARGET_CFLAGS) $(GLIB_CFLAGS)" \
GLIB_LIBS="-L$(STAGING_DIR)/usr/lib -lglib" \
LIBS="-L$(STAGING_DIR)/usr/lib -lglib"