summaryrefslogtreecommitdiff
path: root/openwrt/package/ntpclient
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-11-07 01:12:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-11-07 01:12:51 +0000
commit2e8e51060ffcc46bb1308d7eae4d2bc3456deacf (patch)
treec82e5b250e3389ec4e4fe8ef16361eae61572845 /openwrt/package/ntpclient
parent14a88822fd3f6883af5b4d66f584a3254202fd29 (diff)
downloadmtk-20170518-2e8e51060ffcc46bb1308d7eae4d2bc3456deacf.zip
mtk-20170518-2e8e51060ffcc46bb1308d7eae4d2bc3456deacf.tar.gz
mtk-20170518-2e8e51060ffcc46bb1308d7eae4d2bc3456deacf.tar.bz2
add hotplug stuff to trunk/
SVN-Revision: 2364
Diffstat (limited to 'openwrt/package/ntpclient')
-rw-r--r--openwrt/package/ntpclient/Makefile6
-rw-r--r--openwrt/package/ntpclient/files/ntpclient.init11
2 files changed, 13 insertions, 4 deletions
diff --git a/openwrt/package/ntpclient/Makefile b/openwrt/package/ntpclient/Makefile
index 679e5fc..31fe551 100644
--- a/openwrt/package/ntpclient/Makefile
+++ b/openwrt/package/ntpclient/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ntpclient
PKG_VERSION:=2003_194
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=94e84d5c6023c5e1f3890b28d0a08c92
PKG_SOURCE_URL:=http://doolittle.faludi.com/ntpclient
@@ -26,8 +26,8 @@ $(PKG_BUILD_DIR)/.built:
touch $@
$(IPKG_NTPCLIENT):
- install -d -m0755 $(IDIR_NTPCLIENT)/etc/init.d
- install -m0755 ./files/ntpclient.init $(IDIR_NTPCLIENT)/etc/init.d/S60ntpclient
+ install -d -m0755 $(IDIR_NTPCLIENT)/etc/hotplug.d/iface
+ install -m0755 ./files/ntpclient.init $(IDIR_NTPCLIENT)/etc/hotplug.d/iface/10-ntpclient
install -d -m0755 $(IDIR_NTPCLIENT)/usr/sbin
install -m0755 $(PKG_BUILD_DIR)/ntpclient $(IDIR_NTPCLIENT)/usr/sbin/
$(RSTRIP) $(IDIR_NTPCLIENT)
diff --git a/openwrt/package/ntpclient/files/ntpclient.init b/openwrt/package/ntpclient/files/ntpclient.init
index 923022b..2ad4beb 100644
--- a/openwrt/package/ntpclient/files/ntpclient.init
+++ b/openwrt/package/ntpclient/files/ntpclient.init
@@ -1,2 +1,11 @@
#!/bin/sh
-/usr/sbin/ntpclient -c 1 -s -h pool.ntp.org &
+server=$(nvram get ntp_server)
+case "$ACTION" in
+ ifup)
+ ps x | grep '[n]tpclient' >&- || {
+ route -n 2>&- | grep '0.0.0.0' >&- && /usr/sbin/ntpclient -c 1 -s -h ${server:-pool.ntp.org} &
+ }
+ ;;
+ ifdown)
+ route -n 2>&- | grep '0.0.0.0' >&- || killall ntpclient 2>&- >&- ;;
+esac