summaryrefslogtreecommitdiff
path: root/openwrt/package/olsrd/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-18 14:53:00 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-18 14:53:00 +0000
commit92e1586bec3083edb189ff1ee3440081e243c10a (patch)
treea3c7927db214bac0beb7b14a66d9999ab95d6e73 /openwrt/package/olsrd/patches
parentaa3c1b36deb5584a14798c430fd6e6686e6551fc (diff)
downloadmtk-20170518-92e1586bec3083edb189ff1ee3440081e243c10a.zip
mtk-20170518-92e1586bec3083edb189ff1ee3440081e243c10a.tar.gz
mtk-20170518-92e1586bec3083edb189ff1ee3440081e243c10a.tar.bz2
Convert olsrd to new packaging style, put plugins into sub-packages
SVN-Revision: 936
Diffstat (limited to 'openwrt/package/olsrd/patches')
-rw-r--r--openwrt/package/olsrd/patches/olsrd-0.4.9-opt-flags.diff13
-rw-r--r--openwrt/package/olsrd/patches/olsrd-0.4.9-secure-key-path.path12
2 files changed, 25 insertions, 0 deletions
diff --git a/openwrt/package/olsrd/patches/olsrd-0.4.9-opt-flags.diff b/openwrt/package/olsrd/patches/olsrd-0.4.9-opt-flags.diff
new file mode 100644
index 0000000..c601ae0
--- /dev/null
+++ b/openwrt/package/olsrd/patches/olsrd-0.4.9-opt-flags.diff
@@ -0,0 +1,13 @@
+diff -ruN olsrd-0.4.9-orig/Makefile olsrd-0.4.9-1/Makefile
+--- olsrd-0.4.9-orig/Makefile 2005-03-31 20:39:24.000000000 +0200
++++ olsrd-0.4.9-1/Makefile 2005-04-05 02:14:48.000000000 +0200
+@@ -72,7 +72,8 @@
+ SRCS += $(wildcard src/linux/*.c) $(wildcard src/unix/*.c)
+ HDRS += $(wildcard src/linux/*.h) $(wildcard src/unix/*.h)
+ DEFINES = -Dlinux
+-CFLAGS ?= $(CCWARNINGS) -O2 -g #-DDEBUG #-pg #-march=i686
++OFLAGS ?= -O2 -g
++CFLAGS ?= $(CCWARNINGS) $(OFLAGS) #-DDEBUG #-pg #-march=i686
+ LIBS = -lm -ldl #-pg
+ MAKEDEPEND = makedepend -f $(DEPFILE) $(DEFINES) -Y $(INCLUDES) $(SRCS) >/dev/null 2>&1
+
diff --git a/openwrt/package/olsrd/patches/olsrd-0.4.9-secure-key-path.path b/openwrt/package/olsrd/patches/olsrd-0.4.9-secure-key-path.path
new file mode 100644
index 0000000..fcae759
--- /dev/null
+++ b/openwrt/package/olsrd/patches/olsrd-0.4.9-secure-key-path.path
@@ -0,0 +1,12 @@
+diff -ruN olsrd-0.4.9-orig/lib/secure/src/olsrd_secure.h olsrd-0.4.9-1/lib/secure/src/olsrd_secure.h
+--- olsrd-0.4.9-orig/lib/secure/src/olsrd_secure.h 2005-03-10 20:57:48.000000000 +0100
++++ olsrd-0.4.9-1/lib/secure/src/olsrd_secure.h 2005-04-05 00:51:40.000000000 +0200
+@@ -43,7 +43,7 @@
+
+ #include "olsrd_plugin.h"
+
+-#define KEYFILE "/root/.olsr/olsrd_secure_key"
++#define KEYFILE "/etc/olsrd.d/olsrd_secure_key"
+
+ /* Schemes */
+ #define ONE_CHECKSUM 1