summaryrefslogtreecommitdiff
path: root/openwrt/package/openldap
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-10 16:06:24 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-10 16:06:24 +0000
commit4eb17c54154a9f89d4aeb097bbc17eabf6475443 (patch)
tree8d5d1cb1834673f54bf26163e53efd692657d167 /openwrt/package/openldap
parent2cb724bb3670625ba8cfce342dd40990edad62ee (diff)
downloadmtk-20170518-4eb17c54154a9f89d4aeb097bbc17eabf6475443.zip
mtk-20170518-4eb17c54154a9f89d4aeb097bbc17eabf6475443.tar.gz
mtk-20170518-4eb17c54154a9f89d4aeb097bbc17eabf6475443.tar.bz2
Fix building when host and target systems are same arch
SVN-Revision: 1597
Diffstat (limited to 'openwrt/package/openldap')
-rw-r--r--openwrt/package/openldap/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/openldap/Makefile b/openwrt/package/openldap/Makefile
index 35a15b3..20179b2 100644
--- a/openwrt/package/openldap/Makefile
+++ b/openwrt/package/openldap/Makefile
@@ -78,7 +78,7 @@ $(PKG_BUILD_DIR)/.built:
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
ac_cv_func_memcmp_clean="yes" \
./configure \
--target=$(GNU_TARGET_NAME) \
@@ -128,7 +128,7 @@ $(STAGING_DIR)/usr/lib/libldap.so: $(PKG_BUILD_DIR)/.built
cp -fpR $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib/
cp -fpR $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(STAGING_DIR)/usr/lib/
- touch $(STAGING_DIR)/usr/lib/libldap.so
+ touch $@
install-dev: $(STAGING_DIR)/usr/lib/libldap.so