summaryrefslogtreecommitdiff
path: root/openwrt/package/openssl
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-14 07:16:59 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-14 07:16:59 +0000
commitd895b7ccb8992f5730e9aec157c11158e404252a (patch)
tree99aa1fedf3d6778342320ba5a844bb5d97c7acc7 /openwrt/package/openssl
parent2b7d8f9bf3fc22e8467300d539df3f1301dacb27 (diff)
downloadmtk-20170518-d895b7ccb8992f5730e9aec157c11158e404252a.zip
mtk-20170518-d895b7ccb8992f5730e9aec157c11158e404252a.tar.gz
mtk-20170518-d895b7ccb8992f5730e9aec157c11158e404252a.tar.bz2
Change searchpath from STAGING_DIR/{include,lib} to STAGING_DIR/usr/{include,lib}, Fix static libraries building
SVN-Revision: 648
Diffstat (limited to 'openwrt/package/openssl')
-rw-r--r--openwrt/package/openssl/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/openwrt/package/openssl/Makefile b/openwrt/package/openssl/Makefile
index afa5f30..c33d412 100644
--- a/openwrt/package/openssl/Makefile
+++ b/openwrt/package/openssl/Makefile
@@ -34,13 +34,17 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
(cd $(PKG_BUILD_DIR); \
CFLAGS="-DOPENSSL_NO_KRB5 -DOPENSSL_NO_IDEA -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5" \
PATH=$(TARGET_PATH) ./Configure linux-$(ARCH) --prefix=/ \
- --openssldir=/usr/lib/ssl -L$(STAGING_DIR)/lib -ldl \
- -I$(STAGING_DIR)/include $(OPENSSL_NO_CIPHERS) \
+ --openssldir=/usr/lib/ssl -L$(STAGING_DIR)/usr/lib -ldl \
+ -I$(STAGING_DIR)/usr/include $(OPENSSL_NO_CIPHERS) \
shared no-krb5 no-ec no-engine zlib-dynamic no-hw no-threads )
touch $(PKG_BUILD_DIR)/.configured
$(PKG_BUILD_DIR)/apps/openssl: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -j1 CC=$(TARGET_CC) -C $(PKG_BUILD_DIR) all build-shared
+ $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
+ CC="$(TARGET_CC)" \
+ AR="$(TARGET_CROSS)ar r" \
+ RANLIB="$(TARGET_CROSS)ranlib" \
+ all build-shared
# Work around openssl build bug to link libssl.so with libcrypto.so.
-rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
$(MAKE) -j1 CC=$(TARGET_CC) -C $(PKG_BUILD_DIR) do_linux-shared