summaryrefslogtreecommitdiff
path: root/openwrt/package/openvpn
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-08 07:49:20 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-08 07:49:20 +0000
commit2675c659cb538b38880e837ce183f4b7137d00a0 (patch)
treed92bd0ca1cff5ca4a329e555c9166566e48af402 /openwrt/package/openvpn
parent95464a193845c1e3aba5c54bad269cc8f90ed426 (diff)
downloadmtk-20170518-2675c659cb538b38880e837ce183f4b7137d00a0.zip
mtk-20170518-2675c659cb538b38880e837ce183f4b7137d00a0.tar.gz
mtk-20170518-2675c659cb538b38880e837ce183f4b7137d00a0.tar.bz2
update to 2.0.2, make http proxy an option, default on, adds 5kb
SVN-Revision: 1878
Diffstat (limited to 'openwrt/package/openvpn')
-rw-r--r--openwrt/package/openvpn/Config.in7
-rw-r--r--openwrt/package/openvpn/Makefile11
2 files changed, 13 insertions, 5 deletions
diff --git a/openwrt/package/openvpn/Config.in b/openwrt/package/openvpn/Config.in
index 72f6835..12c35ba 100644
--- a/openwrt/package/openvpn/Config.in
+++ b/openwrt/package/openvpn/Config.in
@@ -1,5 +1,5 @@
config BR2_PACKAGE_OPENVPN
- tristate "openvpn - VPN solution using SSL"
+ tristate "openvpn - Open source VPN solution using SSL"
default m if CONFIG_DEVEL
select BR2_PACKAGE_KMOD_TUN
select BR2_PACKAGE_LIBOPENSSL
@@ -16,6 +16,11 @@ config BR2_PACKAGE_OPENVPN_SERVER
default y
depends BR2_PACKAGE_OPENVPN
+config BR2_PACKAGE_OPENVPN_HTTP
+ bool "Enable http proxy support"
+ default y
+ depends BR2_PACKAGE_OPENVPN
+
config BR2_PACKAGE_OPENVPN_LZO
bool "Enable transparent compression (lzo)"
default y
diff --git a/openwrt/package/openvpn/Makefile b/openwrt/package/openvpn/Makefile
index f6a0b5a..bf0ada2 100644
--- a/openwrt/package/openvpn/Makefile
+++ b/openwrt/package/openvpn/Makefile
@@ -3,9 +3,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openvpn
-PKG_VERSION:=2.0.1
-PKG_RELEASE:=2
-PKG_MD5SUM:=fad7a08c0d68371c2c0e6428bcb98fa5
+PKG_VERSION:=2.0.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=862f8788f080f669b1ae00a74ef68001
PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -28,6 +28,9 @@ endif
ifneq ($(BR2_PACKAGE_OPENVPN_SERVER),y)
DISABLE_SERVER:=--disable-server
endif
+ifneq ($(BR2_PACKAGE_OPENVPN_HTTP),y)
+DISABLE_HTTP:=--disable-http
+endif
$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -62,9 +65,9 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--disable-plugins \
--disable-management \
--disable-socks \
- --disable-http \
$(DISABLE_LZO) \
$(DISABLE_SERVER) \
+ $(DISABLE_HTTP) \
);
touch $(PKG_BUILD_DIR)/.configured