summaryrefslogtreecommitdiff
path: root/openwrt/package/openvpn
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-05 02:16:36 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-05 02:16:36 +0000
commitfd342b1ada887fea48427351a343f42562e04e8b (patch)
tree054175d34d46950baad630df40900e623391037a /openwrt/package/openvpn
parent1262d7ac9bf20c8afbe5ee727aa9693bf2d71203 (diff)
downloadmtk-20170518-fd342b1ada887fea48427351a343f42562e04e8b.zip
mtk-20170518-fd342b1ada887fea48427351a343f42562e04e8b.tar.gz
mtk-20170518-fd342b1ada887fea48427351a343f42562e04e8b.tar.bz2
reorganize/rationalize/format package menuconfig, make updatedd modular
SVN-Revision: 2333
Diffstat (limited to 'openwrt/package/openvpn')
-rw-r--r--openwrt/package/openvpn/Config.in23
-rw-r--r--openwrt/package/openvpn/Makefile6
2 files changed, 18 insertions, 11 deletions
diff --git a/openwrt/package/openvpn/Config.in b/openwrt/package/openvpn/Config.in
index 12c35ba..6117a8e 100644
--- a/openwrt/package/openvpn/Config.in
+++ b/openwrt/package/openvpn/Config.in
@@ -1,5 +1,8 @@
+menu "openvpn........................... Open source VPN solution using SSL"
+
config BR2_PACKAGE_OPENVPN
- tristate "openvpn - Open source VPN solution using SSL"
+ prompt "openvpn........................... Open source VPN solution using SSL"
+ tristate
default m if CONFIG_DEVEL
select BR2_PACKAGE_KMOD_TUN
select BR2_PACKAGE_LIBOPENSSL
@@ -9,20 +12,24 @@ config BR2_PACKAGE_OPENVPN
http://openvpn.net/
Depends: kmod-tun, libpthread, openssl
-
-config BR2_PACKAGE_OPENVPN_SERVER
- bool "Enable server support"
+config BR2_COMPILE_OPENVPN_WITH_SERVER
+ prompt "Enable server support"
+ bool
default y
depends BR2_PACKAGE_OPENVPN
-config BR2_PACKAGE_OPENVPN_HTTP
- bool "Enable http proxy support"
+config BR2_COMPILE_OPENVPN_WITH_HTTP
+ prompt "Enable http proxy support"
+ bool
default y
depends BR2_PACKAGE_OPENVPN
-config BR2_PACKAGE_OPENVPN_LZO
- bool "Enable transparent compression (lzo)"
+config BR2_COMPILE_OPENVPN_WITH_LZO
+ prompt "Enable transparent compression (lzo)"
+ bool
default y
depends BR2_PACKAGE_OPENVPN
select BR2_PACKAGE_LIBLZO
+
+endmenu
diff --git a/openwrt/package/openvpn/Makefile b/openwrt/package/openvpn/Makefile
index d7ae22e..e2589e0 100644
--- a/openwrt/package/openvpn/Makefile
+++ b/openwrt/package/openvpn/Makefile
@@ -19,16 +19,16 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,OPENVPN,openvpn,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
PKG_DEPEND:="libopenssl, kmod-tun"
-ifneq ($(BR2_PACKAGE_OPENVPN_LZO),y)
+ifneq ($(BR2_COMPILE_OPENVPN_WITH_LZO),y)
DISABLE_LZO:=--disable-lzo
else
PKG_DEPEND+=", liblzo"
endif
-ifneq ($(BR2_PACKAGE_OPENVPN_SERVER),y)
+ifneq ($(BR2_COMPILE_OPENVPN_WITH_SERVER),y)
DISABLE_SERVER:=--disable-server
endif
-ifneq ($(BR2_PACKAGE_OPENVPN_HTTP),y)
+ifneq ($(BR2_COMPILE_OPENVPN_WITH_HTTP),y)
DISABLE_HTTP:=--disable-http
endif