summaryrefslogtreecommitdiff
path: root/openwrt/package/pipacs/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-01-09 15:46:03 +0000
committerNicolas Thill <nico@openwrt.org>2006-01-09 15:46:03 +0000
commit2647efdaab4e47aa7c853a2f8eb5d22149c842c3 (patch)
treeb8f090a44c9d871f33347c0fb2d42af2e8d4075e /openwrt/package/pipacs/Makefile
parent50ace1c6d91f3143478c0b72f5ec91d3da44e7ff (diff)
downloadmtk-20170518-2647efdaab4e47aa7c853a2f8eb5d22149c842c3.zip
mtk-20170518-2647efdaab4e47aa7c853a2f8eb5d22149c842c3.tar.gz
mtk-20170518-2647efdaab4e47aa7c853a2f8eb5d22149c842c3.tar.bz2
add pipacs package (thanks to Janos)
SVN-Revision: 2865
Diffstat (limited to 'openwrt/package/pipacs/Makefile')
-rw-r--r--openwrt/package/pipacs/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/openwrt/package/pipacs/Makefile b/openwrt/package/pipacs/Makefile
new file mode 100644
index 0000000..5ec35b9
--- /dev/null
+++ b/openwrt/package/pipacs/Makefile
@@ -0,0 +1,33 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pipacs
+PKG_RELEASE:=2
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PIPACS,pipacs,$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.prepared:
+ mkdir -p $(PKG_BUILD_DIR)
+ cp -a ./src/* $(PKG_BUILD_DIR)
+ touch $@
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS) -I $(STAGING_DIR)/usr/include" \
+ all
+ touch $@
+
+$(IPKG_PIPACS):
+ mkdir -p $(IDIR_PIPACS)/usr/bin
+ install -m0755 $(PKG_BUILD_DIR)/pipacs $(IDIR_PIPACS)/usr/bin
+ $(RSTRIP) $(IDIR_PIPACS)
+ $(IPKG_BUILD) $(IDIR_PIPACS) $(PACKAGE_DIR)