summaryrefslogtreecommitdiff
path: root/openwrt/package/popt/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-03-08 03:57:04 +0000
committerNicolas Thill <nico@openwrt.org>2005-03-08 03:57:04 +0000
commitd9677b625fc48d2c0979fa9811889ce94a1d435e (patch)
tree780d6aeb6f5d7eebefb8d99ce7a1feedd72af9f1 /openwrt/package/popt/Makefile
parenta4fa428eb9402e9d93cf9d07d10b8bf34b3ad78f (diff)
downloadmtk-20170518-d9677b625fc48d2c0979fa9811889ce94a1d435e.zip
mtk-20170518-d9677b625fc48d2c0979fa9811889ce94a1d435e.tar.gz
mtk-20170518-d9677b625fc48d2c0979fa9811889ce94a1d435e.tar.bz2
Update popt release (fix ipkg/rules clean)
SVN-Revision: 348
Diffstat (limited to 'openwrt/package/popt/Makefile')
-rw-r--r--openwrt/package/popt/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/openwrt/package/popt/Makefile b/openwrt/package/popt/Makefile
index ac05eb5..e00a10b 100644
--- a/openwrt/package/popt/Makefile
+++ b/openwrt/package/popt/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME := popt
PKG_VERSION := 1.7
-PKG_RELEASE := 2
+PKG_RELEASE := 3
PKG_SOURCE_SITE := ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/
PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -39,8 +39,11 @@ compile: $(PKG_IPK)
install: $(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list
clean:
+ -cd $(PKG_BUILD_DIR); \
+ ipkg/rules \
+ TOPDIR="$(TOPDIR)" IPKG_RULES_INC="$(TOPDIR)/rules.mk" \
+ INSTALL_DIR="$(STAGING_DIR)" \
+ clean
rm -rf $(PKG_BUILD_DIR)
- rm -f $(STAGING_DIR)/usr/include/popt.h
- rm -f $(STAGING_DIR)/usr/lib/libpopt\*
- rm -f $(PACKAGE_DIR)/lib$(PKG_NAME)\*.ipk
+ rm -r $(PKG_IPK)