summaryrefslogtreecommitdiff
path: root/openwrt/package/ppp/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-03 18:02:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-03 18:02:34 +0000
commitbdd3e06120a90997583ce9844ebedf966f1bbb28 (patch)
tree5e9ace3eceabdc6caec739df481d0555e8c83dbe /openwrt/package/ppp/Makefile
parent0f46e35d7908849dfb1ad6ba4127b36b2e7cb08a (diff)
downloadmtk-20170518-bdd3e06120a90997583ce9844ebedf966f1bbb28.zip
mtk-20170518-bdd3e06120a90997583ce9844ebedf966f1bbb28.tar.gz
mtk-20170518-bdd3e06120a90997583ce9844ebedf966f1bbb28.tar.bz2
remove pppoe init script, add ifup.pppoe for that
SVN-Revision: 1325
Diffstat (limited to 'openwrt/package/ppp/Makefile')
-rw-r--r--openwrt/package/ppp/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/openwrt/package/ppp/Makefile b/openwrt/package/ppp/Makefile
index e1c3907..1b95a76 100644
--- a/openwrt/package/ppp/Makefile
+++ b/openwrt/package/ppp/Makefile
@@ -70,6 +70,7 @@ $(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
CC=$(TARGET_CC) \
COPTS="$(TARGET_CFLAGS)" \
+ HAVE_INET6="1" \
DESTDIR="$(PKG_INSTALL_DIR)/usr" \
all install
touch $@
@@ -88,8 +89,8 @@ $(IPKG_PPP):
$(IPKG_BUILD) $(IDIR_PPP) $(PACKAGE_DIR)
$(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe:
- install -d -m0755 $(IDIR_PPP_MOD_PPPOE)/etc/init.d
- install -m0755 ./files/pppoe.init $(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe
+ install -d -m0755 $(IDIR_PPP_MOD_PPPOE)/sbin
+ install -m0755 ./files/ifup.pppoe $(IDIR_PPP_MOD_PPPOE)/sbin/
$(IPKG_PPP_MOD_PPPOE): $(IDIR_PPP_MOD_PPPOE)/etc/init.d/S50pppoe