summaryrefslogtreecommitdiff
path: root/openwrt/package/ppp
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-08-20 14:30:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-08-20 14:30:28 +0000
commit8ed3f8e05c5df2fce84f197d89af87739db2f953 (patch)
tree5375a527786b25d514b3d52e3119f65f6d837d12 /openwrt/package/ppp
parent858a46382ea4a42141419aabdde8a27a5324e8f1 (diff)
downloadmtk-20170518-8ed3f8e05c5df2fce84f197d89af87739db2f953.zip
mtk-20170518-8ed3f8e05c5df2fce84f197d89af87739db2f953.tar.gz
mtk-20170518-8ed3f8e05c5df2fce84f197d89af87739db2f953.tar.bz2
add support for pppoe over atheros wlan
SVN-Revision: 1702
Diffstat (limited to 'openwrt/package/ppp')
-rw-r--r--openwrt/package/ppp/Makefile2
-rw-r--r--openwrt/package/ppp/patches/205-pppoe_iface_name.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/ppp/Makefile b/openwrt/package/ppp/Makefile
index f248412..0fed25c 100644
--- a/openwrt/package/ppp/Makefile
+++ b/openwrt/package/ppp/Makefile
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.3
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/openwrt/package/ppp/patches/205-pppoe_iface_name.patch b/openwrt/package/ppp/patches/205-pppoe_iface_name.patch
index 522d587..0961eca 100644
--- a/openwrt/package/ppp/patches/205-pppoe_iface_name.patch
+++ b/openwrt/package/ppp/patches/205-pppoe_iface_name.patch
@@ -6,7 +6,7 @@ diff -ruN ppp-2.4.3-orig/pppd/plugins/rp-pppoe/plugin.c ppp-2.4.3-3/pppd/plugins
cmd += 4;
} else if (strlen(cmd) < 4
- || (strncmp(cmd, "eth", 3) && strncmp(cmd, "nas", 3)
-+ || (strncmp(cmd, "eth", 3) && strncmp(cmd, "nas", 3) && strncmp(cmd, "vlan", 4)
++ || (strncmp(cmd, "eth", 3) && strncmp(cmd, "nas", 3) && strncmp(cmd, "vlan", 4) && strncmp(cmd, "ath", 3)
&& strncmp(cmd, "tap", 3) && strncmp(cmd, "br", 2))) {
return 0;
}