summaryrefslogtreecommitdiff
path: root/openwrt/package/pwlib
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-05-07 19:05:51 +0000
committerNicolas Thill <nico@openwrt.org>2006-05-07 19:05:51 +0000
commit670b52a218e9b918b414c815e8e133bc01155207 (patch)
tree8241e69ee181bc68ab343686373bc71a30cf6bab /openwrt/package/pwlib
parent07df01e891bdb99fb2e70a13666dfee1191197fc (diff)
downloadmtk-20170518-670b52a218e9b918b414c815e8e133bc01155207.zip
mtk-20170518-670b52a218e9b918b414c815e8e133bc01155207.tar.gz
mtk-20170518-670b52a218e9b918b414c815e8e133bc01155207.tar.bz2
make asterisk chan_bluetooth and chan_h323 modules optional, link openh323 and pwlib statically.
SVN-Revision: 3737
Diffstat (limited to 'openwrt/package/pwlib')
-rw-r--r--openwrt/package/pwlib/Config.in4
-rw-r--r--openwrt/package/pwlib/Makefile113
2 files changed, 82 insertions, 35 deletions
diff --git a/openwrt/package/pwlib/Config.in b/openwrt/package/pwlib/Config.in
index 1ad5429..0d9d11c 100644
--- a/openwrt/package/pwlib/Config.in
+++ b/openwrt/package/pwlib/Config.in
@@ -1,5 +1,5 @@
-config BR2_PACKAGE_PWLIB
- prompt "pwlib............................. Portable Windows library"
+config BR2_COMPILE_PWLIB
+# prompt "pwlib............................. Portable Windows library"
tristate
select BR2_PACKAGE_LIBPTHREAD
default n
diff --git a/openwrt/package/pwlib/Makefile b/openwrt/package/pwlib/Makefile
index cb933e1..66e806d 100644
--- a/openwrt/package/pwlib/Makefile
+++ b/openwrt/package/pwlib/Makefile
@@ -12,48 +12,95 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,PWLIB,pwlib,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.configured:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- $(TARGET_CONFIGURE_OPTS) \
- ./configure \
- --prefix=$(STAGING_DIR) \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --enable-openh323 \
- --disable-openldap \
- --disable-openssl \
- --disable-ftp \
- --disable-qos \
- --disable-expat \
- --disable-jabber \
- --disable-xmlrpc \
- --disable-ipv6 \
- --disable-sdl \
- --disable-video \
- --disable-socks \
- --disable-ftp \
- --disable-snmp \
- --disable-telnet \
- --disable-serial
- --disable-pop3smtp \
- --disable-http \
- --disable-httpsvc
+ ( cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+ LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ $(TARGET_CONFIGURE_OPTS) \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share \
+ --includedir=/usr/include \
+ --infodir=/usr/share/info \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sbindir=/usr/sbin \
+ --sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
+ $(DISABLE_NLS) \
+ \
+ --enable-minsize \
+ --enable-openh323 \
+ --disable-opal \
+ --disable-internalregex \
+ --disable-plugins \
+ --enable-audio \
+ --disable-alsa \
+ --disable-asn \
+ --disable-avc \
+ --disable-dc \
+ --disable-dtmf \
+ --disable-expat \
+ --disable-ftp \
+ --disable-http \
+ --disable-httpsvc \
+ --disable-ipv6 \
+ --disable-jabber \
+ --disable-openldap \
+ --disable-openssl \
+ --disable-oss \
+ --disable-pipechan \
+ --disable-pop3smtp \
+ --disable-remconn \
+ --disable-resolver \
+ --disable-qos \
+ --disable-sasl \
+ --disable-sdl \
+ --disable-serial \
+ --disable-shm-video \
+ --disable-snmp \
+ --disable-soap \
+ --disable-socks \
+ --disable-stun \
+ --disable-telnet \
+ --disable-tts \
+ --disable-v4l \
+ --disable-v4l2 \
+ --disable-bsdvideo \
+ --disable-video \
+ --disable-vxml \
+ --disable-wavfile \
+ --disable-xmlrpc \
+ );
touch $@
$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
- all install
+ optnoshared
touch $@
+
+install-link:
+ ln -s $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
+
+uninstall-link:
+ rm -rf $(BUILD_DIR)/$(PKG_NAME)
+
+compile-targets: $(PKG_BUILD_DIR)/.built install-link
+clean-targets: uninstall-link