summaryrefslogtreecommitdiff
path: root/openwrt/package/spca5xx
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-09-23 13:44:20 +0000
committerNicolas Thill <nico@openwrt.org>2006-09-23 13:44:20 +0000
commit5912d418f438bdb9cf995949d5ebe08869be43b0 (patch)
tree960e635b9576427e98b3160b755e5602efff0bbd /openwrt/package/spca5xx
parent89dd8554c3aaa3524fe8afb60d7ed39aca2870fc (diff)
downloadmtk-20170518-5912d418f438bdb9cf995949d5ebe08869be43b0.zip
mtk-20170518-5912d418f438bdb9cf995949d5ebe08869be43b0.tar.gz
mtk-20170518-5912d418f438bdb9cf995949d5ebe08869be43b0.tar.bz2
standardize Makefile, remove dup description
SVN-Revision: 4822
Diffstat (limited to 'openwrt/package/spca5xx')
-rw-r--r--openwrt/package/spca5xx/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/openwrt/package/spca5xx/Makefile b/openwrt/package/spca5xx/Makefile
index 7f9cdd8..d063433 100644
--- a/openwrt/package/spca5xx/Makefile
+++ b/openwrt/package/spca5xx/Makefile
@@ -12,24 +12,23 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=spca5xx
PKG_VERSION:=20060501
PKG_RELEASE:=1
-PKG_MD5SUM:=8fcec25715aea10f9ebec5728c37e752
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download/
+PKG_MD5SUM:=8fcec25715aea10f9ebec5728c37e752
PKG_CAT:=zcat
include $(INCLUDE_DIR)/package.mk
#FIXME: add proper dependency handling on kmod-usb-core & kmod-videodev packages
define Package/kmod-spca5xx
-SECTION:=drivers
-CATEGORY:=Drivers
-DEPENDS:=@PACKAGE_KMOD_USB&&PACKAGE_KMOD_VIDEODEV
-TITLE:=Driver for SPCA5xx based USB cameras
-DESCRIPTION:=Driver for SPCA5xx based USB cameras
-URL:=http://mxhaard.free.fr/
-VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+ SECTION:=kernel
+ CATEGORY:=Kernel drivers
+ DEPENDS:=@PACKAGE_KMOD_USB&&PACKAGE_KMOD_VIDEODEV
+ TITLE:=Driver for SPCA5xx based USB cameras
+ URL:=http://mxhaard.free.fr/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
endef
define Build/Compile