summaryrefslogtreecommitdiff
path: root/openwrt/package/switch/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-30 03:09:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-30 03:09:09 +0000
commit31e0ccf22f86a4aa11c032b66bfa0dd4f4b4baaa (patch)
tree41ef7a4753ad7fcc113c4cc8c6b002279788a75b /openwrt/package/switch/Makefile
parent9fb76c1dc29fa25f69228341a06697d40c058adc (diff)
downloadmtk-20170518-31e0ccf22f86a4aa11c032b66bfa0dd4f4b4baaa.zip
mtk-20170518-31e0ccf22f86a4aa11c032b66bfa0dd4f4b4baaa.tar.gz
mtk-20170518-31e0ccf22f86a4aa11c032b66bfa0dd4f4b4baaa.tar.bz2
rewrite of the network scripts and configuration
SVN-Revision: 4323
Diffstat (limited to 'openwrt/package/switch/Makefile')
-rw-r--r--openwrt/package/switch/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/package/switch/Makefile b/openwrt/package/switch/Makefile
index 5513394..860e530 100644
--- a/openwrt/package/switch/Makefile
+++ b/openwrt/package/switch/Makefile
@@ -42,6 +42,10 @@ define Build/Compile
endef
define Package/kmod-switch/install
+ install -m0755 -d $(1)/lib/network/
+ install -m0755 ./files/switch.sh $(1)/lib/network/
+ install -m0755 -d $(1)/etc/modules.d/
+ printf 'switch-core\nswitch-robo\nswitch-adm\n' > $(1)/etc/modules.d/20-switch
install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \
$(1)/lib/modules/$(LINUX_VERSION)