summaryrefslogtreecommitdiff
path: root/openwrt/package/switch
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-06-18 18:30:40 +0000
committerNicolas Thill <nico@openwrt.org>2006-06-18 18:30:40 +0000
commitb65701e8874616ebcdcf7dfa4883a034c52eaf93 (patch)
tree5ef5c474dddaad4f57a06a1d4311a0ccf56f6b3a /openwrt/package/switch
parentf24397711b6a1c2605939b8349dfbe6ab3ea64aa (diff)
downloadmtk-20170518-b65701e8874616ebcdcf7dfa4883a034c52eaf93.zip
mtk-20170518-b65701e8874616ebcdcf7dfa4883a034c52eaf93.tar.gz
mtk-20170518-b65701e8874616ebcdcf7dfa4883a034c52eaf93.tar.bz2
normalize Makefiles.
SVN-Revision: 3998
Diffstat (limited to 'openwrt/package/switch')
-rw-r--r--openwrt/package/switch/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/openwrt/package/switch/Makefile b/openwrt/package/switch/Makefile
index be99a60..e8aa6a0 100644
--- a/openwrt/package/switch/Makefile
+++ b/openwrt/package/switch/Makefile
@@ -3,12 +3,22 @@
include $(TOPDIR)/rules.mk
include $(TOPDIR)/package/kernel.mk
-PKG_NAME := kmod-switch
-PKG_RELEASE := 1
-PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
+PKG_NAME:=kmod-switch
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
include $(TOPDIR)/package/rules.mk
+define Package/kmod-switch
+SECTION:=drivers
+CATEGORY:=Drivers
+DEPENDS:=@LINUX_2_6_BRCM||LINUX_2_4_BRCM
+DEFAULT:=y
+TITLE:=Switch drivers
+DESCRIPTION:=Switch drivers for ADM6996L and BCM53XX RoboSwitch
+VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
@@ -25,16 +35,6 @@ define Build/Compile
modules
endef
-define Package/kmod-switch
- SECTION:=drivers
- CATEGORY:=Drivers
- DEPENDS:=@LINUX_2_6_BRCM||LINUX_2_4_BRCM
- DEFAULT:=y
- TITLE:=Switch drivers
- DESCRIPTION:=Switch drivers for ADM6996L and BCM53XX RoboSwitch
- VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
-endef
-
define Package/kmod-switch/install
install -m0755 -d $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/*.$(LINUX_KMOD_SUFFIX) \