summaryrefslogtreecommitdiff
path: root/openwrt/package/tcp_wrappers/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-08 09:08:38 +0000
commitb7d92815a6aaefcf2aa6240346445530473e9c1e (patch)
tree66a9a28ea0c69b059939becc0f335bc8ec1d5437 /openwrt/package/tcp_wrappers/Makefile
parent322b84237cee9e9adb88d32af8f20f384066866e (diff)
downloadmtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.zip
mtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.tar.gz
mtk-20170518-b7d92815a6aaefcf2aa6240346445530473e9c1e.tar.bz2
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
SVN-Revision: 577
Diffstat (limited to 'openwrt/package/tcp_wrappers/Makefile')
-rw-r--r--openwrt/package/tcp_wrappers/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/tcp_wrappers/Makefile b/openwrt/package/tcp_wrappers/Makefile
index 84f9816..40e7331 100644
--- a/openwrt/package/tcp_wrappers/Makefile
+++ b/openwrt/package/tcp_wrappers/Makefile
@@ -16,6 +16,7 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
# only need libwrap.a at the moment
#PKG_IPK := $(PACKAGE_DIR)/zlib_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+.NOTPARALLEL:
$(DL_DIR)/$(PKG_SOURCE_FILE):
mkdir -p $(DL_DIR)
@@ -28,8 +29,7 @@ $(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE_FILE)
touch $(PKG_BUILD_DIR)/.patched
$(PKG_BUILD_DIR)/libwrap.a: $(PKG_BUILD_DIR)/.patched
-
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) -j1 -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
COPTS="$(TARGET_CFLAGS)" \
LIBS=-lnsl \