summaryrefslogtreecommitdiff
path: root/openwrt/package/tcpdump
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-18 22:40:59 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-18 22:40:59 +0000
commita7d3d46037925a068e4a69474cfbcde10f0fdc47 (patch)
tree62089426b4d3d4182a391a00d90ce970a256639b /openwrt/package/tcpdump
parent1bc4a3a5526211c05ac496a6c6c6c38cd7779a2a (diff)
downloadmtk-20170518-a7d3d46037925a068e4a69474cfbcde10f0fdc47.zip
mtk-20170518-a7d3d46037925a068e4a69474cfbcde10f0fdc47.tar.gz
mtk-20170518-a7d3d46037925a068e4a69474cfbcde10f0fdc47.tar.bz2
Change libpcap, uniformize package makefile, put control file in ./ipkg
SVN-Revision: 683
Diffstat (limited to 'openwrt/package/tcpdump')
-rw-r--r--openwrt/package/tcpdump/Makefile11
-rw-r--r--openwrt/package/tcpdump/ipkg/tcpdump.control (renamed from openwrt/package/tcpdump/tcpdump.control)0
2 files changed, 6 insertions, 5 deletions
diff --git a/openwrt/package/tcpdump/Makefile b/openwrt/package/tcpdump/Makefile
index 2b854c8..cf74ea5 100644
--- a/openwrt/package/tcpdump/Makefile
+++ b/openwrt/package/tcpdump/Makefile
@@ -68,10 +68,10 @@ $(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
CCOPT="$(TARGET_CFLAGS)" INCLS="-I. -I$(STAGING_DIR)/usr/include"
$(IPKG_TCPDUMP): $(PKG_BUILD_DIR)/$(PKG_NAME)
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_TCPDUMP) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
- mkdir -p $(IDIR_TCPDUMP)/usr/sbin
- cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_TCPDUMP)/usr/sbin/
- $(STRIP) $(IDIR_TCPDUMP)/usr/sbin/*
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_TCPDUMP) ./ipkg/$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+ install -m0755 -d $(IDIR_TCPDUMP)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_TCPDUMP)/usr/sbin/
+ $(RSTRIP) $(IDIR_TCPDUMP)
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(IDIR_TCPDUMP) $(PACKAGE_DIR)
@@ -84,4 +84,5 @@ compile: $(IPKG_TCPDUMP)
install: $(INFO_TCPDUMP)
clean:
- rm -rf $(PKG_BUILD_DIR) $(IPKG_TCPDUMP)
+ rm -rf $(PKG_BUILD_DIR)
+ rm -rf $(IPKG_TCPDUMP)
diff --git a/openwrt/package/tcpdump/tcpdump.control b/openwrt/package/tcpdump/ipkg/tcpdump.control
index 8817389..8817389 100644
--- a/openwrt/package/tcpdump/tcpdump.control
+++ b/openwrt/package/tcpdump/ipkg/tcpdump.control