summaryrefslogtreecommitdiff
path: root/openwrt/package/usbutils
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-06-08 19:54:05 +0000
committerNicolas Thill <nico@openwrt.org>2005-06-08 19:54:05 +0000
commit45c6c3628579e4a00c1104413f3364108137f571 (patch)
tree72da19c6e46497fac205668525cec2563d9cf290 /openwrt/package/usbutils
parent417b433766a3236138b965d2820f3a0495c5e182 (diff)
downloadmtk-20170518-45c6c3628579e4a00c1104413f3364108137f571.zip
mtk-20170518-45c6c3628579e4a00c1104413f3364108137f571.tar.gz
mtk-20170518-45c6c3628579e4a00c1104413f3364108137f571.tar.bz2
Always use -R flag with cp (to preserve symlinks)
SVN-Revision: 1175
Diffstat (limited to 'openwrt/package/usbutils')
-rw-r--r--openwrt/package/usbutils/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/usbutils/Makefile b/openwrt/package/usbutils/Makefile
index 9b86509..8e6112c 100644
--- a/openwrt/package/usbutils/Makefile
+++ b/openwrt/package/usbutils/Makefile
@@ -60,8 +60,8 @@ $(PKG_BUILD_DIR)/.built:
$(IPKG_LSUSB):
install -d -m0755 $(IDIR_LSUSB)/usr/share
- cp -fp $(PKG_INSTALL_DIR)/usr/share/usb.ids $(IDIR_LSUSB)/usr/share/
+ cp -fpR $(PKG_INSTALL_DIR)/usr/share/usb.ids $(IDIR_LSUSB)/usr/share/
install -d -m0755 $(IDIR_LSUSB)/usr/sbin
- cp -fp $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(IDIR_LSUSB)/usr/sbin/
+ cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(IDIR_LSUSB)/usr/sbin/
$(RSTRIP) $(IDIR_LSUSB)
$(IPKG_BUILD) $(IDIR_LSUSB) $(PACKAGE_DIR)