summaryrefslogtreecommitdiff
path: root/openwrt/package/vnc-reflector/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2005-12-13 10:22:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2005-12-13 10:22:15 +0000
commit9e0057bdf6f40bf6f30e12450abca07ab9fd21ca (patch)
tree230292c41ee3e9615a0e89f1d7af27a4931b3833 /openwrt/package/vnc-reflector/Makefile
parent10711d79714504f7250684bcef475d35272f5f04 (diff)
downloadmtk-20170518-9e0057bdf6f40bf6f30e12450abca07ab9fd21ca.zip
mtk-20170518-9e0057bdf6f40bf6f30e12450abca07ab9fd21ca.tar.gz
mtk-20170518-9e0057bdf6f40bf6f30e12450abca07ab9fd21ca.tar.bz2
Added vnc-reflector, corrected typo in vpnc/Config.in added then to menuconfig
SVN-Revision: 2648
Diffstat (limited to 'openwrt/package/vnc-reflector/Makefile')
-rwxr-xr-xopenwrt/package/vnc-reflector/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/openwrt/package/vnc-reflector/Makefile b/openwrt/package/vnc-reflector/Makefile
new file mode 100755
index 0000000..6d58abb
--- /dev/null
+++ b/openwrt/package/vnc-reflector/Makefile
@@ -0,0 +1,31 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=vnc-reflector
+PKG_VERSION:=1.2.4
+PKG_RELEASE:=1
+PKG_MD5SUM:=
+PKG_SOURCE_URL:=@SF/vnc-reflector
+PKG_SOURCE:=vnc_reflector-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/vnc_reflector
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,VNC_REFLECTOR,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) STAGING_DIR=$(STAGING_DIR) CC=$(TARGET_CC) -C $(PKG_BUILD_DIR)
+ install -d $(PKG_INSTALL_DIR)/usr/sbin
+ install -m0755 $(PKG_BUILD_DIR)/vncreflector $(PKG_INSTALL_DIR)/usr/sbin/
+ touch $@
+
+$(IPKG_VNC_REFLECTOR):
+ mkdir -p $(IDIR_VNC_REFLECTOR)
+ cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_VNC_REFLECTOR)/
+ $(RSTRIP) $(IDIR_VNC_REFLECTOR)
+ $(IPKG_BUILD) $(IDIR_VNC_REFLECTOR) $(PACKAGE_DIR)