summaryrefslogtreecommitdiff
path: root/openwrt/package/vnc-reflector/patches
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-12-14 00:39:11 +0000
committerNicolas Thill <nico@openwrt.org>2005-12-14 00:39:11 +0000
commit86d260bcd7adbdcdcbeeea74118612d45be36ba6 (patch)
tree64a5345d25baeca175ba2562cfa213013d0f3379 /openwrt/package/vnc-reflector/patches
parent3f774a5f9d4c5b3c98f93866a56fac0b80189a0f (diff)
downloadmtk-20170518-86d260bcd7adbdcdcbeeea74118612d45be36ba6.zip
mtk-20170518-86d260bcd7adbdcdcbeeea74118612d45be36ba6.tar.gz
mtk-20170518-86d260bcd7adbdcdcbeeea74118612d45be36ba6.tar.bz2
add an Id tag to the Makefile, set md5sum, don't use PKG_INSTALL_DIR since upstream does not provide a make install target
SVN-Revision: 2667
Diffstat (limited to 'openwrt/package/vnc-reflector/patches')
-rw-r--r--openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch20
1 files changed, 12 insertions, 8 deletions
diff --git a/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch b/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch
index 8bc04c2..fb409ac 100644
--- a/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch
+++ b/openwrt/package/vnc-reflector/patches/01-honor_include_lib_path.patch
@@ -1,21 +1,25 @@
-diff -urN orig/vnc_reflector/Makefile vnc_reflector/Makefile
---- orig/vnc_reflector/Makefile 2003-04-16 19:32:42.000000000 +0200
-+++ vnc_reflector/Makefile 2005-12-13 11:08:09.000000000 +0100
-@@ -14,7 +14,7 @@
+--- vnc_reflector/Makefile.orig 2005-12-14 01:25:53.000000000 +0100
++++ vnc_reflector/Makefile 2005-12-14 01:28:05.000000000 +0100
+@@ -14,10 +14,11 @@
#
# Variables you might want to edit: CFLAGS, CONFFLAGS
-IFLAGS = -I.
-+IFLAGS = -I. -I$(STAGING_DIR)/usr/include
++IFLAGS = -I. -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
++OFLAGS = -O2
# Production
- CFLAGS = -O2 $(IFLAGS)
-@@ -29,7 +29,7 @@
+-CFLAGS = -O2 $(IFLAGS)
++CFLAGS = $(OFLAGS) $(IFLAGS)
+ # Debug (strict)
+ #CFLAGS = -g -pedantic -Wall $(IFLAGS)
+ # Debug (profiling)
+@@ -29,7 +30,7 @@
CONFFLAGS = -DUSE_POLL
# Link with zlib and JPEG libraries
-LDFLAGS = -L/usr/local/lib -lz -ljpeg
-+LDFLAGS = -L$(STAGING_DIR)/usr/lib -lz -ljpeg
++LDFLAGS = -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lz -ljpeg
PROG = vncreflector