summaryrefslogtreecommitdiff
path: root/openwrt/package/vncrepeater/patches
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-04-10 14:42:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-04-10 14:42:25 +0000
commit6669ffcf51d1c2e728bca4834cd279c94d630b30 (patch)
treecbb610eebca5950d3d40c9d9238fa361d0b209bc /openwrt/package/vncrepeater/patches
parentdc8dd57941885687dbe8557e413779911d64fc0b (diff)
downloadmtk-20170518-6669ffcf51d1c2e728bca4834cd279c94d630b30.zip
mtk-20170518-6669ffcf51d1c2e728bca4834cd279c94d630b30.tar.gz
mtk-20170518-6669ffcf51d1c2e728bca4834cd279c94d630b30.tar.bz2
Add vncrepeater, with uClibc++ linking, needs therefore testing
SVN-Revision: 3605
Diffstat (limited to 'openwrt/package/vncrepeater/patches')
-rw-r--r--openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch b/openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch
new file mode 100644
index 0000000..7df92a0
--- /dev/null
+++ b/openwrt/package/vncrepeater/patches/01-uclibcxx_linking.patch
@@ -0,0 +1,23 @@
+diff -urN vncrepeater-0.007/Makefile vncrepeater-0.007.new/Makefile
+--- vncrepeater-0.007/Makefile 2005-10-03 20:22:48.000000000 +0200
++++ vncrepeater-0.007.new/Makefile 2006-04-10 16:15:50.495599944 +0200
+@@ -1,15 +1,15 @@
+ CFLAGS=-Wall
+ repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o
+- g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o
++ $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o -nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -luClibc++
+
+ repeater.o: repeater.cpp
+- g++ $(CFLAGS) -c repeater.cpp
++ $(CC) $(CFLAGS) -c repeater.cpp
+
+ repeaterproc.o: repeaterproc.cpp
+- g++ $(CFLAGS) -c repeaterproc.cpp
++ $(CC) $(CFLAGS) -c repeaterproc.cpp
+
+ openbsd_stringfuncs.o: openbsd_stringfuncs.cpp
+- g++ $(CFLAGS) -c openbsd_stringfuncs.cpp
++ $(CC) $(CFLAGS) -c openbsd_stringfuncs.cpp
+
+ clean:
+ rm -f *.o repeater