summaryrefslogtreecommitdiff
path: root/openwrt/package/wireless-tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-05-30 20:47:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-05-30 20:47:25 +0000
commita9589b5e4142ee0f5581a3b625a3c25e11dbba6f (patch)
treeb6ee5a26a5f3ebed5066b80e86f635dc3888864a /openwrt/package/wireless-tools
parent1545f46b7695c13482a38b93a27297e95c9ff93a (diff)
downloadmtk-20170518-a9589b5e4142ee0f5581a3b625a3c25e11dbba6f.zip
mtk-20170518-a9589b5e4142ee0f5581a3b625a3c25e11dbba6f.tar.gz
mtk-20170518-a9589b5e4142ee0f5581a3b625a3c25e11dbba6f.tar.bz2
make wireless-tools install headers and library into the staging dir
SVN-Revision: 1114
Diffstat (limited to 'openwrt/package/wireless-tools')
-rw-r--r--openwrt/package/wireless-tools/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/openwrt/package/wireless-tools/Makefile b/openwrt/package/wireless-tools/Makefile
index fe83163..4d132b9 100644
--- a/openwrt/package/wireless-tools/Makefile
+++ b/openwrt/package/wireless-tools/Makefile
@@ -40,3 +40,16 @@ $(IPKG_WIRELESS_TOOLS):
cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/iw{config,getid,list,priv,spy} $(IDIR_WIRELESS_TOOLS)/usr/sbin/
$(RSTRIP) $(IDIR_WIRELESS_TOOLS)
$(IPKG_BUILD) $(IDIR_WIRELESS_TOOLS) $(PACKAGE_DIR)
+
+install-dev:
+ mkdir -p $(STAGING_DIR)/usr/{lib,include}
+ cp -a $(PKG_BUILD_DIR)/libiw.so* $(STAGING_DIR)/usr/lib/
+ ln -sf libiw.so.28 $(STAGING_DIR)/usr/lib/libiw.so
+ cp -a $(PKG_BUILD_DIR)/{iwlib,wireless}.h $(STAGING_DIR)/usr/include/
+
+uninstall-dev:
+ rm -f $(STAGING_DIR)/usr/lib/libiw.*
+ rm -f $(STAGING_DIR)/usr/include/{iwlib,wireless}.h
+
+compile: install-dev
+clean: uninstall-dev