summaryrefslogtreecommitdiff
path: root/openwrt/package/xinetd
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 21:30:44 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 21:30:44 +0000
commitb3a10b754621fcae357be6aecb9124596848e2d1 (patch)
treee3cdb4d7412c1e3fcfceda877756f53f3d68a157 /openwrt/package/xinetd
parent9011cdcedfd683016bf43b4799a3144ad672d38e (diff)
downloadmtk-20170518-b3a10b754621fcae357be6aecb9124596848e2d1.zip
mtk-20170518-b3a10b754621fcae357be6aecb9124596848e2d1.tar.gz
mtk-20170518-b3a10b754621fcae357be6aecb9124596848e2d1.tar.bz2
Tweak package build
SVN-Revision: 978
Diffstat (limited to 'openwrt/package/xinetd')
-rw-r--r--openwrt/package/xinetd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/xinetd/Makefile b/openwrt/package/xinetd/Makefile
index 71b9cf2..7dcb20e 100644
--- a/openwrt/package/xinetd/Makefile
+++ b/openwrt/package/xinetd/Makefile
@@ -49,15 +49,15 @@ $(PKG_BUILD_DIR)/.configured:
--without-libwrap \
--with-loadavg \
);
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR)
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ build install
+ touch $@
$(IPKG_XINETD):
install -d -m0755 $(IDIR_XINETD)/etc