summaryrefslogtreecommitdiff
path: root/openwrt/package/zlib/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 12:12:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 12:12:59 +0000
commit6b758a5dc3bc19877e9c3eefc12ce04d7041334f (patch)
tree4478a1a9bc90bda0dab2c84fce154218f3e11aae /openwrt/package/zlib/Makefile
parent9ae81d33764adae7a2a68cd54087bc5a9c68a181 (diff)
downloadmtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.zip
mtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.tar.gz
mtk-20170518-6b758a5dc3bc19877e9c3eefc12ce04d7041334f.tar.bz2
lots of small package changes and dependency cleanups for the V= stuff
SVN-Revision: 2230
Diffstat (limited to 'openwrt/package/zlib/Makefile')
-rw-r--r--openwrt/package/zlib/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/package/zlib/Makefile b/openwrt/package/zlib/Makefile
index 2d88d51..099ac03 100644
--- a/openwrt/package/zlib/Makefile
+++ b/openwrt/package/zlib/Makefile
@@ -18,7 +18,7 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,ZLIB,zlib,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); \
$(TARGET_CONFIGURE_OPTS) \
LDSHARED="$(TARGET_CC) -shared -Wl,-soname,libz.so.1" \
@@ -29,7 +29,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
);
touch $@
-$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS) $(CFLAGS_LARGEFILE)" \
@@ -60,5 +60,5 @@ uninstall-dev:
rm -rf $(STAGING_DIR)/usr/include/zlib.h
rm -rf $(STAGING_DIR)/usr/lib/libz.*
-compile: install-dev
-clean: uninstall-dev
+compile-targets: install-dev
+clean-targets: uninstall-dev