summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 23:45:47 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 23:45:47 +0000
commit32a56766a8fd913e6bb2e228e687aa3a3b3d9dc2 (patch)
tree8bf5e8aed2e54f4a984436a449dd60bec15759e5 /openwrt/package
parent858ab2e3f9a27fe59cad14c81cb219f5889429ff (diff)
downloadmtk-20170518-32a56766a8fd913e6bb2e228e687aa3a3b3d9dc2.zip
mtk-20170518-32a56766a8fd913e6bb2e228e687aa3a3b3d9dc2.tar.gz
mtk-20170518-32a56766a8fd913e6bb2e228e687aa3a3b3d9dc2.tar.bz2
revert last change and add a different fix
SVN-Revision: 4046
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/iptables/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index 35bba6d..f8f5909 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -21,6 +21,10 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_MENU:=IPv4 / IPv6 firewall administration
include $(INCLUDE_DIR)/package.mk
+ifeq ($(DUMP),)
+-include $(LINUX_DIR)/.config
+include $(INCLUDE_DIR)/netfilter.mk
+endif
define Package/iptables
SECTION:=net
@@ -209,9 +213,6 @@ define Package/ip6tables/install
endef
define BuildPlugin
-include $(LINUX_DIR)/.config
-include $(INCLUDE_DIR)/netfilter.mk
-
define Package/$(1)/install
install -m0755 -d $$(1)/usr/lib/iptables
for m in $$(patsubst xt_%,ipt_%,$(2)); do \