summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-16 21:39:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-16 21:39:42 +0000
commit5b244391701e4d2fc72a80d90ae98c3baf88ef6a (patch)
treec32e3c18c2c67f071ca5ceaa1122063a2513bb3d /openwrt/package
parent7df7b7433402c56c193180a513c9d7a0ebd90b18 (diff)
downloadmtk-20170518-5b244391701e4d2fc72a80d90ae98c3baf88ef6a.zip
mtk-20170518-5b244391701e4d2fc72a80d90ae98c3baf88ef6a.tar.gz
mtk-20170518-5b244391701e4d2fc72a80d90ae98c3baf88ef6a.tar.bz2
use rm -f in package-rebuild and add extra options to the default configure template
SVN-Revision: 3965
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/rules.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/openwrt/package/rules.mk b/openwrt/package/rules.mk
index 77a6595..37dc2a0 100644
--- a/openwrt/package/rules.mk
+++ b/openwrt/package/rules.mk
@@ -47,7 +47,7 @@ define Build/DefaultTargets
rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
package-rebuild: FORCE
- @-rm $(PKG_BUILD_DIR)/.built
+ @-rm -f $(PKG_BUILD_DIR)/.built
define Build/DefaultTargets
endef
@@ -211,8 +211,9 @@ define Build/Prepare
endef
define Build/Configure/Default
- @(cd $(PKG_BUILD_DIR); \
+ @(cd $(PKG_BUILD_DIR)/$(3); \
[ -x configure ] && \
+ $(2) \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \