summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-18 13:09:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-18 13:09:32 +0000
commit9a9f6205c4ac50d7240c43004381f9445e9e86c7 (patch)
tree4a02bc5c57c61222dfc3320f7ab50d0821cbb6a1 /openwrt/package
parent7eda64608c43f18cc9070dbe8e72a1f24563b957 (diff)
downloadmtk-20170518-9a9f6205c4ac50d7240c43004381f9445e9e86c7.zip
mtk-20170518-9a9f6205c4ac50d7240c43004381f9445e9e86c7.tar.gz
mtk-20170518-9a9f6205c4ac50d7240c43004381f9445e9e86c7.tar.bz2
add support for conffiles,preinst,... through templates
SVN-Revision: 3982
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/rules.mk17
1 files changed, 14 insertions, 3 deletions
diff --git a/openwrt/package/rules.mk b/openwrt/package/rules.mk
index 37dc2a0..d7719eb 100644
--- a/openwrt/package/rules.mk
+++ b/openwrt/package/rules.mk
@@ -77,6 +77,12 @@ define Package/Default
DESCRIPTION:=
endef
+define BuildIPKGVariable
+pkg_$(subst -,_,$(1))_$(2) = $$(Package/$(1)/$(2))
+export pkg_$(subst -,_,$(1))_$(2)
+COMMANDS += if [ -n "$$$$$$$$pkg_$(subst -,_,$(1))_$(2)" ]; then echo "$$$$$$$$pkg_$(subst -,_,$(1))_$(2)" > $(2); fi;
+endef
+
define BuildPackage
$(eval $(call Package/Default))
$(eval $(call Package/$(1)))
@@ -145,6 +151,11 @@ define BuildPackage
echo "@@";
endif
+ $(eval $(call BuildIPKGVariable,$(1),conffiles))
+ $(eval $(call BuildIPKGVariable,$(1),preinst))
+ $(eval $(call BuildIPKGVariable,$(1),postinst))
+ $(eval $(call BuildIPKGVariable,$(1),prerm))
+ $(eval $(call BuildIPKGVariable,$(1),postrm))
$$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
mkdir -p $$(IDIR_$(1))/CONTROL
echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
@@ -163,9 +174,9 @@ define BuildPackage
echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
chmod 644 $$(IDIR_$(1))/CONTROL/control
- for file in conffiles preinst postinst prerm postrm; do \
- [ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
- done
+ (cd $$(IDIR_$(1))/CONTROL; \
+ $(COMMANDS) \
+ )
$$(IPKG_$(1)): $$(IDIR_$(1))/CONTROL/control $(PKG_BUILD_DIR)/.built
$(call Package/$(1)/install,$$(IDIR_$(1)))