summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-07-25 18:12:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-07-25 18:12:30 +0000
commit44be142cb2327bedaa6c95c8c8faa8b23d56a8da (patch)
treeafcf3b3740fc39a5ea7f635214f0309413035faf /openwrt/package
parent3df71b4f5e12934d9d231a600f43bc9c5ad2b321 (diff)
downloadmtk-20170518-44be142cb2327bedaa6c95c8c8faa8b23d56a8da.zip
mtk-20170518-44be142cb2327bedaa6c95c8c8faa8b23d56a8da.tar.gz
mtk-20170518-44be142cb2327bedaa6c95c8c8faa8b23d56a8da.tar.bz2
use 127.0.0.1 as dns server and point dnsmasq to /tmp/resolv.conf
SVN-Revision: 4282
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/base-files/Makefile1
-rw-r--r--openwrt/package/base-files/default/etc/resolv.conf2
-rw-r--r--openwrt/package/dnsmasq/files/dnsmasq.conf1
3 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index 8fccf79..01ea967 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -153,7 +153,6 @@ define Package/base-files$(TARGET)/install
mkdir -p $(1)/usr/bin
mkdir -p $(1)/sys
mkdir -p $(1)/www
- ln -sf /tmp/resolv.conf $(1)/etc/resolv.conf
ln -sf /proc/mounts $(1)/etc/mtab
rm -f $(1)/var
ln -sf /tmp $(1)/var
diff --git a/openwrt/package/base-files/default/etc/resolv.conf b/openwrt/package/base-files/default/etc/resolv.conf
new file mode 100644
index 0000000..9617eac
--- /dev/null
+++ b/openwrt/package/base-files/default/etc/resolv.conf
@@ -0,0 +1,2 @@
+nameserver 127.0.0.1
+search lan
diff --git a/openwrt/package/dnsmasq/files/dnsmasq.conf b/openwrt/package/dnsmasq/files/dnsmasq.conf
index 7aed3a3..43acd85 100644
--- a/openwrt/package/dnsmasq/files/dnsmasq.conf
+++ b/openwrt/package/dnsmasq/files/dnsmasq.conf
@@ -8,6 +8,7 @@ localise-queries
local=/lan/
domain=lan
expand-hosts
+resolv-file=/tmp/resolv.conf
@ifdef dhcp_enable
dhcp-range=@@start@@,@@end@@,@@netmask@@,@@lease@@