summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-06-18 18:05:20 +0000
committerNicolas Thill <nico@openwrt.org>2006-06-18 18:05:20 +0000
commit52f8d5bdce1bce9fc1119c1674fd5be24453a22c (patch)
tree6942b7366d21e272fa7b72f91dd15d938bf529a2 /openwrt/package
parente5c5a14618e03b343d76315a2bd2edf6abe6056e (diff)
downloadmtk-20170518-52f8d5bdce1bce9fc1119c1674fd5be24453a22c.zip
mtk-20170518-52f8d5bdce1bce9fc1119c1674fd5be24453a22c.tar.gz
mtk-20170518-52f8d5bdce1bce9fc1119c1674fd5be24453a22c.tar.bz2
move source files to src/.
SVN-Revision: 3993
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/robocfg/Makefile11
-rw-r--r--openwrt/package/robocfg/src/Makefile12
-rw-r--r--openwrt/package/robocfg/src/etc53xx.h (renamed from openwrt/package/robocfg/etc53xx.h)0
-rw-r--r--openwrt/package/robocfg/src/robocfg.c (renamed from openwrt/package/robocfg/robocfg.c)0
4 files changed, 20 insertions, 3 deletions
diff --git a/openwrt/package/robocfg/Makefile b/openwrt/package/robocfg/Makefile
index 81cf99a..49f6005 100644
--- a/openwrt/package/robocfg/Makefile
+++ b/openwrt/package/robocfg/Makefile
@@ -16,15 +16,20 @@ TITLE:=BCM5325E/536x switch configuration utility
DESCRIPTION:=Broadcom BCM5325E/536x switch configuration utility
endef
+define Build/Prepare
+ mkdir -p $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/robocfg robocfg.c
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+ all
endef
define Package/robocfg/install
install -d -m0755 $(1)/sbin
install -m0755 $(PKG_BUILD_DIR)/robocfg $(1)/sbin/
- $(RSTRIP) $(1)
- $(IPKG_BUILD) $(1) $(PACKAGE_DIR)
endef
$(eval $(call BuildPackage,robocfg))
diff --git a/openwrt/package/robocfg/src/Makefile b/openwrt/package/robocfg/src/Makefile
new file mode 100644
index 0000000..fa763ed
--- /dev/null
+++ b/openwrt/package/robocfg/src/Makefile
@@ -0,0 +1,12 @@
+# $Id$
+
+all: robocfg
+
+%.o: %.c
+ $(CC) $(CFLAGS) $(EXTRA_CFLAGS) -c -o $@ $^
+
+robocfg: robocfg.o
+ $(CC) -o $@ $^
+
+clean:
+ rm -f *.o robocfg
diff --git a/openwrt/package/robocfg/etc53xx.h b/openwrt/package/robocfg/src/etc53xx.h
index 4e1f8ad..4e1f8ad 100644
--- a/openwrt/package/robocfg/etc53xx.h
+++ b/openwrt/package/robocfg/src/etc53xx.h
diff --git a/openwrt/package/robocfg/robocfg.c b/openwrt/package/robocfg/src/robocfg.c
index b8fc49f..b8fc49f 100644
--- a/openwrt/package/robocfg/robocfg.c
+++ b/openwrt/package/robocfg/src/robocfg.c