summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-05-27 05:58:23 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-05-27 05:58:23 +0000
commit5d8f11e1190586d3e983a3527c1173a41875a258 (patch)
treec9b858ac87d6a528ca95e5beead3edc60fcf4cb2 /openwrt/package
parent3fb31228dd42e0011f2b17024b98b4444b5fdab7 (diff)
downloadmtk-20170518-5d8f11e1190586d3e983a3527c1173a41875a258.zip
mtk-20170518-5d8f11e1190586d3e983a3527c1173a41875a258.tar.gz
mtk-20170518-5d8f11e1190586d3e983a3527c1173a41875a258.tar.bz2
ipcontrack is a module
SVN-Revision: 1079
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/iptables/kernelconfig.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/openwrt/package/iptables/kernelconfig.mk b/openwrt/package/iptables/kernelconfig.mk
index 00d2349..a0b420f 100644
--- a/openwrt/package/iptables/kernelconfig.mk
+++ b/openwrt/package/iptables/kernelconfig.mk
@@ -17,23 +17,23 @@ ext-$(CONFIG_IP_NF_MATCH_LENGTH) += length
ext-$(CONFIG_IP_NF_MATCH_TTL) += ttl
ext-$(CONFIG_IP_NF_MATCH_TCPMSS) += tcpmss
ext-$(CONFIG_IP_NF_MATCH_HELPER) += helper
-ext-$(CONFIG_IP_NF_MATCH_STATE) += state
-ext-$(CONFIG_IP_NF_MATCH_CONNTRACK) += conntrack
+#ext-$(CONFIG_IP_NF_MATCH_STATE) += state
+#ext-$(CONFIG_IP_NF_MATCH_CONNTRACK) += conntrack
ext-$(CONFIG_IP_NF_MATCH_UNCLEAN) += unclean
ext-$(CONFIG_IP_NF_MATCH_OWNER) += owner
ext-$(CONFIG_IP_NF_MATCH_PHYSDEV) += physdev
ext-$(CONFIG_IP_NF_MATCH_LAYER7) += layer7
-ext-$(CONFIG_IP_NF_TARGET_MASQUERADE) += MASQUERADE
+#ext-$(CONFIG_IP_NF_TARGET_MASQUERADE) += MASQUERADE
ext-$(CONFIG_IP_NF_TARGET_REDIRECT) += REDIRECT
ext-$(CONFIG_IP_NF_TARGET_REJECT) += REJECT
ext-$(CONFIG_IP_NF_TARGET_TOS) += TOS
ext-$(CONFIG_IP_NF_TARGET_ECN) += ECN
ext-$(CONFIG_IP_NF_TARGET_DSCP) += DSCP
ext-$(CONFIG_IP_NF_TARGET_MARK) += MARK
-ext-$(CONFIG_IP_NF_TARGET_LOG) += LOG
+#ext-$(CONFIG_IP_NF_TARGET_LOG) += LOG
ext-$(CONFIG_IP_NF_TARGET_ULOG) += ULOG
-ext-$(CONFIG_IP_NF_TARGET_TCPMSS) += TCPMSS
+#ext-$(CONFIG_IP_NF_TARGET_TCPMSS) += TCPMSS
# add extensions that don't depend on kernel config
ext-m += TTL
-ext-y += icmp standard tcp udp
+ext-y += icmp standard tcp udp state MASQUERADE conntrack TCPMSS LOG