summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-08-04 09:14:20 +0000
committerMike Baker <mbm@openwrt.org>2006-08-04 09:14:20 +0000
commit20922bcde7a20037c761104f81a901f97dd82e18 (patch)
tree183e534ced13bf3afe8767403ace06d1eaac4d12 /openwrt/package
parent1dee38a88eb0b1189c910a1a2d466834cc4a2f14 (diff)
downloadmtk-20170518-20922bcde7a20037c761104f81a901f97dd82e18.zip
mtk-20170518-20922bcde7a20037c761104f81a901f97dd82e18.tar.gz
mtk-20170518-20922bcde7a20037c761104f81a901f97dd82e18.tar.bz2
fix everything I broke with the previous patches
SVN-Revision: 4436
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/busybox/Makefile7
-rw-r--r--openwrt/package/dropbear/Makefile2
-rw-r--r--openwrt/package/iptables/Makefile4
3 files changed, 8 insertions, 5 deletions
diff --git a/openwrt/package/busybox/Makefile b/openwrt/package/busybox/Makefile
index afe7c59..67f7ce1 100644
--- a/openwrt/package/busybox/Makefile
+++ b/openwrt/package/busybox/Makefile
@@ -38,12 +38,13 @@ endef
define Build/Configure
$(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
- yes '' | $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" -C $(PKG_BUILD_DIR) oldconfig
+ yes '' | PATH="$(TARGET_PATH)" $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" \
+ -C $(PKG_BUILD_DIR) oldconfig
endef
define Package/busybox/install
- $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" PREFIX="$(1)" \
- EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install
+ PATH="$(TARGET_PATH)" $(MAKE) CC="$(TARGET_CC)" CROSS="$(TARGET_CROSS)" \
+ PREFIX="$(1)" EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install
-rm -rf $(1)/lib64
endef
diff --git a/openwrt/package/dropbear/Makefile b/openwrt/package/dropbear/Makefile
index cfb2c41..9ffc782 100644
--- a/openwrt/package/dropbear/Makefile
+++ b/openwrt/package/dropbear/Makefile
@@ -82,10 +82,12 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
+ LD="$(TARGET_CC)" \
PROGRAMS="dropbear dbclient dropbearkey scp" \
MULTI=1 SCPPROGRESS=1
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
+ LD="$(TARGET_CC)" \
PROGRAMS="dropbearconvert"
endef
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index a28b8fd..bf81240 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -161,7 +161,7 @@ endef
define Build/Compile
chmod a+x $(PKG_BUILD_DIR)/extensions/.*-test*
mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ PATH="$(TARGET_PATH)" $(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
CC="$(TARGET_CC)" COPT_FLAGS="$(TARGET_CFLAGS)" \
KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
@@ -171,7 +171,7 @@ endef
define Build/InstallDev
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ PATH="$(TARGET_PATH)" $(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
CC="$(TARGET_CC)" COPT_FLAGS="$(TARGET_CFLAGS)" \
KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \