summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-06-21 02:32:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-06-21 02:32:39 +0000
commit4ced39ac6f9b653d884b4753c92cac87f5107df5 (patch)
tree8cd2667e6e5c2c158d498d4a45f1bcfcd24c23de /openwrt/package
parent4e24e35fa9083cfe57d7b1fe7b51c5f2f6515f18 (diff)
downloadmtk-20170518-4ced39ac6f9b653d884b4753c92cac87f5107df5.zip
mtk-20170518-4ced39ac6f9b653d884b4753c92cac87f5107df5.tar.gz
mtk-20170518-4ced39ac6f9b653d884b4753c92cac87f5107df5.tar.bz2
add INCLUDE_DIR variable for $(TOPDIR)/include
SVN-Revision: 4033
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/alsa/Makefile4
-rw-r--r--openwrt/package/base-files/Makefile4
-rw-r--r--openwrt/package/bridge/Makefile2
-rw-r--r--openwrt/package/broadcom-wl/Makefile4
-rw-r--r--openwrt/package/busybox/Makefile2
-rw-r--r--openwrt/package/diag/Makefile4
-rw-r--r--openwrt/package/dnsmasq/Makefile2
-rw-r--r--openwrt/package/dropbear/Makefile2
-rw-r--r--openwrt/package/ebtables/Makefile2
-rw-r--r--openwrt/package/fuse/Makefile4
-rw-r--r--openwrt/package/haserl/Makefile2
-rw-r--r--openwrt/package/hostap/Makefile4
-rw-r--r--openwrt/package/hostapd/Makefile2
-rw-r--r--openwrt/package/iproute2/Makefile2
-rw-r--r--openwrt/package/ipsec-tools/Makefile2
-rw-r--r--openwrt/package/ipset/Makefile2
-rw-r--r--openwrt/package/iptables/Makefile6
-rw-r--r--openwrt/package/libpcap/Makefile2
-rw-r--r--openwrt/package/linux-atm/Makefile2
-rw-r--r--openwrt/package/madwifi/Makefile4
-rw-r--r--openwrt/package/mini_fo/Makefile4
-rw-r--r--openwrt/package/mtd/Makefile2
-rw-r--r--openwrt/package/nvram/Makefile2
-rw-r--r--openwrt/package/openssl/Makefile2
-rw-r--r--openwrt/package/openswan/Makefile4
-rw-r--r--openwrt/package/pcmcia-cs/Makefile2
-rw-r--r--openwrt/package/ppp/Makefile2
-rw-r--r--openwrt/package/pptp/Makefile2
-rw-r--r--openwrt/package/robocfg/Makefile2
-rw-r--r--openwrt/package/shfs/Makefile4
-rw-r--r--openwrt/package/spca5xx/Makefile4
-rw-r--r--openwrt/package/switch/Makefile4
-rw-r--r--openwrt/package/udev/Makefile2
-rw-r--r--openwrt/package/ueagle-atm/Makefile4
-rw-r--r--openwrt/package/util-linux/Makefile2
-rw-r--r--openwrt/package/wireless-tools/Makefile2
-rw-r--r--openwrt/package/wlcompat/Makefile4
-rw-r--r--openwrt/package/zd1211/Makefile4
-rw-r--r--openwrt/package/zlib/Makefile2
39 files changed, 56 insertions, 56 deletions
diff --git a/openwrt/package/alsa/Makefile b/openwrt/package/alsa/Makefile
index 5f6a330..7046bfe 100644
--- a/openwrt/package/alsa/Makefile
+++ b/openwrt/package/alsa/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=alsa-driver
PKG_VERSION:=1.0.11
@@ -13,7 +13,7 @@ PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/driver/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_CAT:=bzcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
ifeq ($(LINUX_KARCH),i386)
KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-i386/mach-generic -I$(LINUX_DIR)/include/asm-i386/mach-default
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index bb20894..7db0d05 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
PKG_RELEASE:=8
@@ -12,7 +12,7 @@ ifeq ($(REV),)
REV:=0
endif
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
ifneq ($(DUMP),1)
TARGET:=-$(BOARD)-$(KERNEL)
diff --git a/openwrt/package/bridge/Makefile b/openwrt/package/bridge/Makefile
index f2b178a..c3e682c 100644
--- a/openwrt/package/bridge/Makefile
+++ b/openwrt/package/bridge/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=@SF/bridge
PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/bridge
SECTION:=base
diff --git a/openwrt/package/broadcom-wl/Makefile b/openwrt/package/broadcom-wl/Makefile
index 6fe22ed..7983943 100644
--- a/openwrt/package/broadcom-wl/Makefile
+++ b/openwrt/package/broadcom-wl/Makefile
@@ -1,7 +1,7 @@
# $Id: Makefile 2480 2005-11-14 02:07:33Z nbd $
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=broadcom-wl
PKG_VERSION:=4.80.9.2
@@ -14,7 +14,7 @@ PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
PKG_MD5SUM:=7d9fab2c611369bbe075c3924ea77450
PKG_CAT:=bzcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-brcm-wl
SECTION:=drivers
diff --git a/openwrt/package/busybox/Makefile b/openwrt/package/busybox/Makefile
index 6b2e0c5..b444129 100644
--- a/openwrt/package/busybox/Makefile
+++ b/openwrt/package/busybox/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads
PKG_MD5SUM:=19a0b475169335f17e421cf644616fe7
PKG_CAT:=bzcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/busybox
SECTION:=base
diff --git a/openwrt/package/diag/Makefile b/openwrt/package/diag/Makefile
index ab28e72..de6ab8d 100644
--- a/openwrt/package/diag/Makefile
+++ b/openwrt/package/diag/Makefile
@@ -1,14 +1,14 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=kmod-diag
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-diag
SECTION:=drivers
diff --git a/openwrt/package/dnsmasq/Makefile b/openwrt/package/dnsmasq/Makefile
index a05ec0e..09770da 100644
--- a/openwrt/package/dnsmasq/Makefile
+++ b/openwrt/package/dnsmasq/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
PKG_MD5SUM:=489198ec87101087043adc98bbe062dc
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/dnsmasq
SECTION:=base
diff --git a/openwrt/package/dropbear/Makefile b/openwrt/package/dropbear/Makefile
index 0409e66..b76d3da 100644
--- a/openwrt/package/dropbear/Makefile
+++ b/openwrt/package/dropbear/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=http://matt.ucc.asn.au/dropbear/releases/
PKG_MD5SUM:=ca8e53a766faec831882831364568421
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/dropbear
SECTION:=base
diff --git a/openwrt/package/ebtables/Makefile b/openwrt/package/ebtables/Makefile
index 814ac68..87f93de 100644
--- a/openwrt/package/ebtables/Makefile
+++ b/openwrt/package/ebtables/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=@SF/ebtables
PKG_MD5SUM:=f07111fcc1966be669278433c35dcc28
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/ebtables
SECTION:=base
diff --git a/openwrt/package/fuse/Makefile b/openwrt/package/fuse/Makefile
index b708423..06777c8 100644
--- a/openwrt/package/fuse/Makefile
+++ b/openwrt/package/fuse/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=fuse
PKG_VERSION:=2.5.3
@@ -15,7 +15,7 @@ PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-fuse
SECTION:=drivers
diff --git a/openwrt/package/haserl/Makefile b/openwrt/package/haserl/Makefile
index ec940ea..53a28a7 100644
--- a/openwrt/package/haserl/Makefile
+++ b/openwrt/package/haserl/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=@SF/haserl
PKG_MD5SUM:=bd9195d086566f56634c0bcbbbcbebea
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/haserl
SECTION:=base
diff --git a/openwrt/package/hostap/Makefile b/openwrt/package/hostap/Makefile
index 21abfe2..612b2b7 100644
--- a/openwrt/package/hostap/Makefile
+++ b/openwrt/package/hostap/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=hostap-driver
PKG_VERSION:=0.4.9
@@ -15,7 +15,7 @@ PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-hostap
SECTION:=drivers
diff --git a/openwrt/package/hostapd/Makefile b/openwrt/package/hostapd/Makefile
index 867cda6..7fc77f8 100644
--- a/openwrt/package/hostapd/Makefile
+++ b/openwrt/package/hostapd/Makefile
@@ -14,7 +14,7 @@ PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/hostapd
SECTION:=net
diff --git a/openwrt/package/iproute2/Makefile b/openwrt/package/iproute2/Makefile
index 9cf1eb9..bbbcc75 100644
--- a/openwrt/package/iproute2/Makefile
+++ b/openwrt/package/iproute2/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/ip
SECTION:=base
diff --git a/openwrt/package/ipsec-tools/Makefile b/openwrt/package/ipsec-tools/Makefile
index 667884d..5567036 100644
--- a/openwrt/package/ipsec-tools/Makefile
+++ b/openwrt/package/ipsec-tools/Makefile
@@ -14,7 +14,7 @@ PKG_CAT:=bzcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/ipsec-tools
SECTION:=base
diff --git a/openwrt/package/ipset/Makefile b/openwrt/package/ipset/Makefile
index d245090..0991148 100644
--- a/openwrt/package/ipset/Makefile
+++ b/openwrt/package/ipset/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=http://ipset.netfilter.org
PKG_MD5SUM:=1709424cc2cdb925d4fb6fd5fcaefc26
PKG_CAT:=bzcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/ipset
SECTION:=base
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index 7490277..f1a7de1 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.3.5
@@ -20,10 +20,10 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_MENU:=IPv4 / IPv6 firewall administration
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
ifeq ($(DUMP),)
include $(LINUX_DIR)/.config
-include $(TOPDIR)/include/netfilter.mk
+include $(INCLUDE_DIR)/netfilter.mk
endif
define Package/iptables
diff --git a/openwrt/package/libpcap/Makefile b/openwrt/package/libpcap/Makefile
index 2d7aecf..0ded09a 100644
--- a/openwrt/package/libpcap/Makefile
+++ b/openwrt/package/libpcap/Makefile
@@ -14,7 +14,7 @@ PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/libpcap
SECTION:=base
diff --git a/openwrt/package/linux-atm/Makefile b/openwrt/package/linux-atm/Makefile
index 15b3f7d..48a94ed 100644
--- a/openwrt/package/linux-atm/Makefile
+++ b/openwrt/package/linux-atm/Makefile
@@ -14,7 +14,7 @@ PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/linux-atm
SECTION:=libs
diff --git a/openwrt/package/madwifi/Makefile b/openwrt/package/madwifi/Makefile
index 7bdb7ec..57210c0 100644
--- a/openwrt/package/madwifi/Makefile
+++ b/openwrt/package/madwifi/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=madwifi
PKG_VERSION:=0.9.0
@@ -54,7 +54,7 @@ MADWIFI_MAKEOPTS= -C $(PKG_BUILD_DIR) \
LDOPTS="" \
DOMULTI=1
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
ifeq ($(findstring AHB,$(BUS)),AHB)
define Build/Compile/ahb
diff --git a/openwrt/package/mini_fo/Makefile b/openwrt/package/mini_fo/Makefile
index 0180f81..2922908 100644
--- a/openwrt/package/mini_fo/Makefile
+++ b/openwrt/package/mini_fo/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mini_fo
PKG_VERSION:=0.6.2pre1
@@ -13,7 +13,7 @@ PKG_SOURCE_URL:=http://www.denx.de/twiki/pub/Know/MiniFOHome/
PKG_SOURCE:=mini_fo-0-6-2-pre1.tar.bz2
PKG_CAT:=bzcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-mini-fo
SECTION:=drivers
diff --git a/openwrt/package/mtd/Makefile b/openwrt/package/mtd/Makefile
index 01dfcd6..80409a9 100644
--- a/openwrt/package/mtd/Makefile
+++ b/openwrt/package/mtd/Makefile
@@ -7,7 +7,7 @@ PKG_RELEASE:=4
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/mtd
SECTION:=base
diff --git a/openwrt/package/nvram/Makefile b/openwrt/package/nvram/Makefile
index cf76c7c..11e8936 100644
--- a/openwrt/package/nvram/Makefile
+++ b/openwrt/package/nvram/Makefile
@@ -7,7 +7,7 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/nvram
SECTION:=base
diff --git a/openwrt/package/openssl/Makefile b/openwrt/package/openssl/Makefile
index 39fe6b4..78e17a2 100644
--- a/openwrt/package/openssl/Makefile
+++ b/openwrt/package/openssl/Makefile
@@ -20,7 +20,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-rmd160 no-aes192
OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-krb5 no-threads zlib-dynamic no-engines
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/libopenssl
SECTION:=base
diff --git a/openwrt/package/openswan/Makefile b/openwrt/package/openswan/Makefile
index f810965..61aefe4 100644
--- a/openwrt/package/openswan/Makefile
+++ b/openwrt/package/openswan/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=openswan
PKG_VERSION:=2.4.5
@@ -13,7 +13,7 @@ PKG_SOURCE_URL:=http://www.openswan.org/download
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-openswan
SECTION:=drivers
diff --git a/openwrt/package/pcmcia-cs/Makefile b/openwrt/package/pcmcia-cs/Makefile
index 2c7b229..388b431 100644
--- a/openwrt/package/pcmcia-cs/Makefile
+++ b/openwrt/package/pcmcia-cs/Makefile
@@ -14,7 +14,7 @@ PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/pcmcia-cs
SECTION:=base
diff --git a/openwrt/package/ppp/Makefile b/openwrt/package/ppp/Makefile
index edd9a5e..813b722 100644
--- a/openwrt/package/ppp/Makefile
+++ b/openwrt/package/ppp/Makefile
@@ -15,7 +15,7 @@ PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/ppp
SECTION:=net
diff --git a/openwrt/package/pptp/Makefile b/openwrt/package/pptp/Makefile
index 6d01ce1..0478b4c 100644
--- a/openwrt/package/pptp/Makefile
+++ b/openwrt/package/pptp/Makefile
@@ -12,7 +12,7 @@ PKG_SOURCE_URL:=@SF/pptpclient
PKG_MD5SUM:=9a706327fb9827541d7c86d48ceb9631
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/pptp
SECTION:=base
diff --git a/openwrt/package/robocfg/Makefile b/openwrt/package/robocfg/Makefile
index ca0f83d..8451ac5 100644
--- a/openwrt/package/robocfg/Makefile
+++ b/openwrt/package/robocfg/Makefile
@@ -8,7 +8,7 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/robocfg
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/robocfg
SECTION:=base
diff --git a/openwrt/package/shfs/Makefile b/openwrt/package/shfs/Makefile
index 057358b..5617693 100644
--- a/openwrt/package/shfs/Makefile
+++ b/openwrt/package/shfs/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=shfs
PKG_VERSION:=0.35
@@ -15,7 +15,7 @@ PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-shfs
SECTION:=drivers
diff --git a/openwrt/package/spca5xx/Makefile b/openwrt/package/spca5xx/Makefile
index 86233fc..001a64f 100644
--- a/openwrt/package/spca5xx/Makefile
+++ b/openwrt/package/spca5xx/Makefile
@@ -1,7 +1,7 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=spca5xx
PKG_VERSION:=20060301
@@ -13,7 +13,7 @@ PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
#FIXME: add proper dependency handling on kmod-usb-core & kmod-videodev packages
define Package/kmod-spca5xx
diff --git a/openwrt/package/switch/Makefile b/openwrt/package/switch/Makefile
index cb5f346..befae34 100644
--- a/openwrt/package/switch/Makefile
+++ b/openwrt/package/switch/Makefile
@@ -1,14 +1,14 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=kmod-switch
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-switch
SECTION:=drivers
diff --git a/openwrt/package/udev/Makefile b/openwrt/package/udev/Makefile
index 5d39716..0156115 100644
--- a/openwrt/package/udev/Makefile
+++ b/openwrt/package/udev/Makefile
@@ -19,7 +19,7 @@ PKG_CAT:=bzcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/udev
SECTION:=base
diff --git a/openwrt/package/ueagle-atm/Makefile b/openwrt/package/ueagle-atm/Makefile
index 6d003f6..6d9c739 100644
--- a/openwrt/package/ueagle-atm/Makefile
+++ b/openwrt/package/ueagle-atm/Makefile
@@ -1,7 +1,7 @@
# $Id: Makefile 2767 2005-12-25 02:10:14Z wbx $
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ueagle-atm
PKG_VERSION:=1.0d1
@@ -15,7 +15,7 @@ PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
#FIXME: add dependency on kmod-usb-core
define Package/kmod-ueagle-atm
diff --git a/openwrt/package/util-linux/Makefile b/openwrt/package/util-linux/Makefile
index 673ade4..798e3c8 100644
--- a/openwrt/package/util-linux/Makefile
+++ b/openwrt/package/util-linux/Makefile
@@ -16,7 +16,7 @@ PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/fdisk
SECTION:=base
diff --git a/openwrt/package/wireless-tools/Makefile b/openwrt/package/wireless-tools/Makefile
index 368d3eb..5f12058 100644
--- a/openwrt/package/wireless-tools/Makefile
+++ b/openwrt/package/wireless-tools/Makefile
@@ -14,7 +14,7 @@ PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/wireless-tools
SECTION:=base
diff --git a/openwrt/package/wlcompat/Makefile b/openwrt/package/wlcompat/Makefile
index d5feede..e6ec27e 100644
--- a/openwrt/package/wlcompat/Makefile
+++ b/openwrt/package/wlcompat/Makefile
@@ -1,14 +1,14 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=kmod-wlcompat
PKG_RELEASE:=3
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/kmod-wlcompat
SECTION:=drivers
diff --git a/openwrt/package/zd1211/Makefile b/openwrt/package/zd1211/Makefile
index 1c79922..ba7308c 100644
--- a/openwrt/package/zd1211/Makefile
+++ b/openwrt/package/zd1211/Makefile
@@ -1,7 +1,7 @@
# $Id: Makefile 3297 2006-03-02 23:42:52Z florian $
include $(TOPDIR)/rules.mk
-include $(TOPDIR)/include/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=zd1211
PKG_VERSION:=r69
@@ -13,7 +13,7 @@ PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
PKG_CAT:=zcat
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
#FIXME: add proper dependency handling on kmod-usb-core packages
define Package/kmod-zd1211
diff --git a/openwrt/package/zlib/Makefile b/openwrt/package/zlib/Makefile
index 8e497c2..6c56062 100644
--- a/openwrt/package/zlib/Makefile
+++ b/openwrt/package/zlib/Makefile
@@ -14,7 +14,7 @@ PKG_CAT:=bzcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
define Package/zlib
SECTION:=base