summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-04-30 19:54:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-04-30 19:54:58 +0000
commit4d3c9e0734333498bb60f9e906f5ff66c73b8bb9 (patch)
treee369d109b2d5dc4ddc3c653cbe5af35b7c20da43 /openwrt/package
parent12163738553c2d0738cd229560ac54801cb6903c (diff)
downloadmtk-20170518-4d3c9e0734333498bb60f9e906f5ff66c73b8bb9.zip
mtk-20170518-4d3c9e0734333498bb60f9e906f5ff66c73b8bb9.tar.gz
mtk-20170518-4d3c9e0734333498bb60f9e906f5ff66c73b8bb9.tar.bz2
add ipkg to image builder
SVN-Revision: 774
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/Makefile2
-rw-r--r--openwrt/package/sdk/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index 99c2c72..bf9d04f 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -76,7 +76,7 @@ package-$(BR2_PACKAGE_LIBPQ) += postgresql
DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++
DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
-SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge
+SDK_DEFAULT_PACKAGES:=busybox dnsmasq iptables wireless-tools dropbear bridge ipkg
SDK_DEFAULT_COMPILE:=$(patsubst %,%-compile,$(SDK_DEFAULT_PACKAGES))
all: compile install
diff --git a/openwrt/package/sdk/Makefile b/openwrt/package/sdk/Makefile
index dba08ca..2345fcc 100644
--- a/openwrt/package/sdk/Makefile
+++ b/openwrt/package/sdk/Makefile
@@ -47,7 +47,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2:
mkdir -p $(IB_BUILD_DIR)/include
mkdir -p $(IB_BUILD_DIR)/packages
(cd $(PACKAGE_DIR); \
- cp busybox_* kmod-brcm-* kmod-wlcompat* dnsmasq_* iptables_* dropbear_* kmod-diag_* \
+ cp ipkg_* busybox_* kmod-brcm-* kmod-wlcompat* dnsmasq_* iptables_* dropbear_* kmod-diag_* \
wireless-tools_* zlib* bridge_* ppp_* ppp-pppoe* kmod-ppp* openwrt-utils* $(IB_BUILD_DIR)/packages/; \
)
egrep '^[^(include|prepare|compile|install)]' < $(TOPDIR)/target/jffs2/Makefile > $(IB_BUILD_DIR)/include/jffs2.mk