summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-07-10 21:17:45 +0000
committerMike Baker <mbm@openwrt.org>2006-07-10 21:17:45 +0000
commite81ba9aa44cd444fbbecb37ac38b01da6298fa98 (patch)
tree99cab60ff14aa7822de80a3c9acce75b201bd453 /openwrt/package
parent1e53a6bb694b569d104044cf6a54d94005d335ae (diff)
downloadmtk-20170518-e81ba9aa44cd444fbbecb37ac38b01da6298fa98.zip
mtk-20170518-e81ba9aa44cd444fbbecb37ac38b01da6298fa98.tar.gz
mtk-20170518-e81ba9aa44cd444fbbecb37ac38b01da6298fa98.tar.bz2
add a new FORCEREBUILD option to Package/<name> to force a package to be rebuilt each time make is run
SVN-Revision: 4123
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/base-files/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index 376bd53..daa15d0 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -38,6 +38,7 @@ define Package/base-files$(TARGET)
TITLE:=OpenWrt system scripts
DESCRIPTION:=Base filesystem for OpenWrt
VERSION:=$(PKG_RELEASE)
+ FORCEREBUILD:=y
endef
define -ar7-2.4/conffiles
@@ -89,6 +90,7 @@ define Package/libgcc
TITLE:=GCC support library
VERSION:=$(LIBGCC_VERSION)-$(PKG_RELEASE)
DESCRIPTION:=$(TITLE)
+ FORCEREBUILD:=n
endef
define Package/libpthread
@@ -97,6 +99,7 @@ define Package/libpthread
VERSION:=$(UCLIBC_VERSION)-$(PKG_RELEASE)
TITLE:=POSIX thread library
DESCRIPTION:=POSIX thread library
+ FORCEREBUILD:=n
endef
@@ -105,6 +108,7 @@ define Package/uclibc
VERSION:=$(UCLIBC_VERSION)-$(PKG_RELEASE)
TITLE:=C library
DESCRIPTION:=C library for embedded systems
+ FORCEREBUILD:=n
endef
define Build/Prepare