summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-10 15:06:24 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-10 15:06:24 +0000
commit3ec895cbdda35cfd86f3795b4f5a8de8ca4e60ca (patch)
tree8d3b1a8c24796fae96adf155c9da27ec5f0ae16a /openwrt/package
parent7223882cd14e0ec1d104ea384219de5173c59815 (diff)
downloadmtk-20170518-3ec895cbdda35cfd86f3795b4f5a8de8ca4e60ca.zip
mtk-20170518-3ec895cbdda35cfd86f3795b4f5a8de8ca4e60ca.tar.gz
mtk-20170518-3ec895cbdda35cfd86f3795b4f5a8de8ca4e60ca.tar.bz2
Add some missing headers to STAGING_DIR, required to build php4 extension
SVN-Revision: 1399
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/postgresql/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
index de021ba..1f37bb7 100644
--- a/openwrt/package/postgresql/Makefile
+++ b/openwrt/package/postgresql/Makefile
@@ -95,6 +95,7 @@ $(IPKG_PGSQL_CLI):
$(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/include
+ cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
@@ -106,6 +107,7 @@ install-dev: $(STAGING_DIR)/usr/lib/libpq.so
uninstall-dev:
rm -rf \
+ $(STAGING_DIR)/usr/include/libpq \
$(STAGING_DIR)/usr/include/libpq-fe.h \
$(STAGING_DIR)/usr/include/postgres_ext.h \
$(STAGING_DIR)/usr/include/postgresql \