summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-02-28 07:31:29 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-02-28 07:31:29 +0000
commit62cb331e8ebc7fdcea9726eaf9974780cc3179d7 (patch)
tree7761fcfe78e0ad31d585ad7eaeaec572f96f36f6 /openwrt/package
parentd0b14b4791475fe234c4d11b9142ca0647eee513 (diff)
downloadmtk-20170518-62cb331e8ebc7fdcea9726eaf9974780cc3179d7.zip
mtk-20170518-62cb331e8ebc7fdcea9726eaf9974780cc3179d7.tar.gz
mtk-20170518-62cb331e8ebc7fdcea9726eaf9974780cc3179d7.tar.bz2
Added support for : save-password( --enable-password-save), smaller executable (--enable-small)
SVN-Revision: 3284
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/openvpn/Config.in12
-rw-r--r--openwrt/package/openvpn/Makefile8
2 files changed, 20 insertions, 0 deletions
diff --git a/openwrt/package/openvpn/Config.in b/openwrt/package/openvpn/Config.in
index 860a39f..3feffa3 100644
--- a/openwrt/package/openvpn/Config.in
+++ b/openwrt/package/openvpn/Config.in
@@ -38,4 +38,16 @@ config BR2_COMPILE_OPENVPN_WITH_LZO
depends BR2_PACKAGE_OPENVPN
select BR2_PACKAGE_LIBLZO
+config BR2_COMPILE_OPENVPN_WITH_PASSWORD_SAVE
+ prompt "Enable password saving"
+ bool
+ default y
+ depends BR2_PACKAGE_OPENVPN
+
+config BR2_COMPILE_OPENVPN_WITH_SMALL
+ prompt "Enable smaller executable size (disable OCC, usage message, and verb 4 parm list)"
+ bool
+ default n
+ depends BR2_PACKAGE_OPENVPN
+
endmenu
diff --git a/openwrt/package/openvpn/Makefile b/openwrt/package/openvpn/Makefile
index e5e1275..5ae1a31 100644
--- a/openwrt/package/openvpn/Makefile
+++ b/openwrt/package/openvpn/Makefile
@@ -38,6 +38,12 @@ endif
ifneq ($(BR2_COMPILE_OPENVPN_WITH_HTTP),y)
DISABLE_HTTP:=--disable-http
endif
+ifeq ($(BR2_COMPILE_OPENVPN_WITH_PASSWORD_SAVE),y)
+ENABLE_PASSWORD_SAVE:=--enable-password-save
+endif
+ifeq ($(BR2_COMPILE_OPENVPN_WITH_SMALL),y)
+ENABLE_SMALL:=--enable-small
+endif
$(PKG_BUILD_DIR)/.configured:
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -76,6 +82,8 @@ $(PKG_BUILD_DIR)/.configured:
$(DISABLE_OPENSSL) \
$(DISABLE_SERVER) \
$(DISABLE_HTTP) \
+ $(ENABLE_PASSWORD_SAVE) \
+ $(ENABLE_SMALL) \
);
touch $(PKG_BUILD_DIR)/.configured