summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-04 00:03:48 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-09-04 00:03:48 +0000
commit916d5c6b146856dd67488e4cd239fccfc280f0c8 (patch)
treea308a7ea62294791ade7d73bb172fd273458fbb2 /openwrt/package
parent344fd2fbd591412e85efc5d70a3328f3ec1914e0 (diff)
downloadmtk-20170518-916d5c6b146856dd67488e4cd239fccfc280f0c8.zip
mtk-20170518-916d5c6b146856dd67488e4cd239fccfc280f0c8.tar.gz
mtk-20170518-916d5c6b146856dd67488e4cd239fccfc280f0c8.tar.bz2
link to specific header, just to be safe
SVN-Revision: 1841
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/mtd/Makefile6
-rw-r--r--openwrt/package/mtd/mtd.c4
2 files changed, 9 insertions, 1 deletions
diff --git a/openwrt/package/mtd/Makefile b/openwrt/package/mtd/Makefile
index bfbb301..b2090a6 100644
--- a/openwrt/package/mtd/Makefile
+++ b/openwrt/package/mtd/Makefile
@@ -7,6 +7,10 @@ PKG_RELEASE := 1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
+ifeq ($(LINUX_VERSION),2.4.30)
+VER=-DLINUX_24
+endif
+
include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
@@ -16,7 +20,7 @@ $(PKG_BUILD_DIR)/.prepared:
touch $@
$(PKG_BUILD_DIR)/.built:
- $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+ $(TARGET_CC) -I$(LINUX_DIR)/include $(VER) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
touch $@
$(IPKG_MTD):
diff --git a/openwrt/package/mtd/mtd.c b/openwrt/package/mtd/mtd.c
index 69ef064..e559864 100644
--- a/openwrt/package/mtd/mtd.c
+++ b/openwrt/package/mtd/mtd.c
@@ -40,7 +40,11 @@
#include <sys/reboot.h>
#include <string.h>
+#ifdef LINUX_24
#include <linux/mtd/mtd.h>
+#else
+#include <mtd/mtd-user.h>
+#endif
#define TRX_MAGIC 0x30524448 /* "HDR0" */
#define BUFSIZE (10 * 1024)