summaryrefslogtreecommitdiff
path: root/openwrt/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-04-21 00:37:58 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-04-21 00:37:58 +0000
commit519c9c34e7ac20ccd86e6618eefe69f1eb2ef242 (patch)
tree74ee2b5c6d98f3a7851d61730656f6878422e859 /openwrt/package
parentcdd74416bc3e33e3f234859674747595631d092a (diff)
downloadmtk-20170518-519c9c34e7ac20ccd86e6618eefe69f1eb2ef242.zip
mtk-20170518-519c9c34e7ac20ccd86e6618eefe69f1eb2ef242.tar.gz
mtk-20170518-519c9c34e7ac20ccd86e6618eefe69f1eb2ef242.tar.bz2
clean up package titles/descriptions
SVN-Revision: 3686
Diffstat (limited to 'openwrt/package')
-rw-r--r--openwrt/package/busybox/Makefile4
-rw-r--r--openwrt/package/iptables/Makefile38
-rw-r--r--openwrt/package/rules.mk18
3 files changed, 36 insertions, 24 deletions
diff --git a/openwrt/package/busybox/Makefile b/openwrt/package/busybox/Makefile
index 5ccbe22..812e12a 100644
--- a/openwrt/package/busybox/Makefile
+++ b/openwrt/package/busybox/Makefile
@@ -20,8 +20,8 @@ SECTION:=base
CATEGORY:=Base system
DEFAULT:=y
TITLE:=Core utilities for embedded Linux
-DESCRIPTION:=The Swiss Army Knife of embedded Linux. It slices, it dices, it\\\
-makes Julian Fries.
+DESCRIPTION:=The Swiss Army Knife of embedded Linux. \\\
+It slices, it dices, it makes Julian Fries.
URL:=http://busybox.net/
endef
diff --git a/openwrt/package/iptables/Makefile b/openwrt/package/iptables/Makefile
index cc7c84a..bca0610 100644
--- a/openwrt/package/iptables/Makefile
+++ b/openwrt/package/iptables/Makefile
@@ -38,8 +38,9 @@ define Package/iptables-mod-conntrack
SECTION:=net
CATEGORY:=Base system
DEPENDS:=iptables
-TITLE:=iptables extensions for connection tracking
-DESCRIPTION:=Includes: \\\
+TITLE:=connection tracking modules
+DESCRIPTION:=iptables extensions for connection tracking \\\
+Includes: \\\
* libipt_conntrack \\\
* libipt_helper \\\
* libipt_connmark/CONNMARK
@@ -50,8 +51,9 @@ define Package/iptables-mod-filter
SECTION:=net
CATEGORY:=Base system
DEPENDS:=iptables
-TITLE:=iptables extensions for packet content inspection
-DESCRIPTION:=Includes: \\\
+TITLE:=filter modules
+DESCRIPTION:=iptables extensions for packet content inspection\\\
+Includes: \\\
* libipt_ipp2p \\\
* libipt_layer7
@@ -61,8 +63,9 @@ define Package/iptables-mod-imq
SECTION:=net
CATEGORY:=Base system
DEPENDS:=iptables
-TITLE:=iptables extension for IMQ support
-DESCRIPTION:=Includes: \\\
+TITLE:=IMQ support
+DESCRIPTION:=iptables extension for IMQ support\\\
+Includes: \\\
* libipt_IMQ
endef
@@ -71,8 +74,9 @@ define Package/iptables-mod-ipopt
SECTION:=net
CATEGORY:=Base system
DEPENDS:=iptables
-TITLE:=iptables extensions for matching/changing IP packet options
-DESCRIPTION:=Includes: \\\
+TITLE:=IP/Packet option modules
+DESCRIPTION:=iptables extensions for matching/changing IP packet options\\\
+Includes: \\\
* libipt_dscp/DSCP \\\
* libipt_ecn/ECN \\\
* libipt_length \\\
@@ -88,8 +92,9 @@ define Package/iptables-mod-ipsec
SECTION:=net
CATEGORY:=Base system
DEPENDS:=iptables
-TITLE:=iptables extensions for matching ipsec traffic
-DESCRIPTION:=Includes: \\\
+TITLE:=IPSec extensions
+DESCRIPTION:=iptables extensions for matching ipsec traffic\\\
+Includes: \\\
* libipt_ah \\\
* libipt_esp
@@ -99,8 +104,9 @@ define Package/iptables-mod-nat
SECTION:=net
CATEGORY:=Base system
DEPENDS:=iptables
-TITLE:=iptables extensions for different NAT targets
-DESCRIPTION:=Includes: \\\
+TITLE:=extra NAT targets
+DESCRIPTION:=iptables extensions for different NAT targets\\\
+Includes: \\\
* libipt_REDIRECT
endef
@@ -108,8 +114,9 @@ define Package/iptables-mod-ulog
SECTION:=net
CATEGORY:=Base system
DEPENDS:=iptables
-TITLE:=iptables extensions for user-space packet logging
-DESCRIPTION:=Includes: \\\
+TITLE:=user-space packet logging
+DESCRIPTION:=iptables extensions for user-space packet logging\\\
+Includes: \\\
* libipt_ULOG
endef
@@ -118,7 +125,8 @@ SECTION:=net
CATEGORY:=Base system
DEPENDS:=iptables
TITLE:=other extra iptables extensions
-DESCRIPTION:=Includes: \\\
+DESCRIPTION:=other extra iptables extensions\\\
+Includes: \\\
* libipt_limit \\\
* libipt_owner \\\
* libipt_physdev \\\
diff --git a/openwrt/package/rules.mk b/openwrt/package/rules.mk
index 2ff710a..5316deb 100644
--- a/openwrt/package/rules.mk
+++ b/openwrt/package/rules.mk
@@ -56,21 +56,26 @@ define BuildPackage
$(eval $(call Package/Default))
$(eval $(call Package/$(1)))
-ifeq ($$(TITLE),)
+ifeq ($(TITLE),)
$$(error Package $(1) has no TITLE)
endif
-ifeq ($$(CATEGORY),)
+ifeq ($(CATEGORY),)
$$(error Package $(1) has no CATEGORY)
endif
-ifeq ($$(PRIORITY),)
+ifeq ($(PRIORITY),)
$$(error Package $(1) has no PRIORITY)
endif
-ifeq ($$(VERSION),)
+ifeq ($(VERSION),)
$$(error Package $(1) has no VERSION)
endif
-ifeq ($$(PKGARCH),)
+ifeq ($(PKGARCH),)
PKGARCH:=$(ARCH)
endif
+$(eval
+ifeq ($(DESCRIPTION),)
+DESCRIPTION:=$(TITLE)
+endif
+)
IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
@@ -128,8 +133,7 @@ $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
echo "Maintainer: $(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Description: $(TITLE)" >> $$(IDIR_$(1))/CONTROL/control
- echo " $(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
+ echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
chmod 644 $$(IDIR_$(1))/CONTROL/control
for file in conffiles preinst postinst prerm postrm; do \
[ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \