summaryrefslogtreecommitdiff
path: root/openwrt/rules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 19:55:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 19:55:54 +0000
commit42d657027e98eacafa1c32e0dab4d7a60de6f891 (patch)
treecf1c274b03893abf6087c4a7cc0e777a68c372d1 /openwrt/rules.mk
parent343946f7a7da0f256dafd572b6bad54ea3dc3d8f (diff)
downloadmtk-20170518-42d657027e98eacafa1c32e0dab4d7a60de6f891.zip
mtk-20170518-42d657027e98eacafa1c32e0dab4d7a60de6f891.tar.gz
mtk-20170518-42d657027e98eacafa1c32e0dab4d7a60de6f891.tar.bz2
fix gcc compile
SVN-Revision: 5032
Diffstat (limited to 'openwrt/rules.mk')
-rw-r--r--openwrt/rules.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/openwrt/rules.mk b/openwrt/rules.mk
index 8e5294e..b9859dbd 100644
--- a/openwrt/rules.mk
+++ b/openwrt/rules.mk
@@ -8,7 +8,9 @@
-include $(TOPDIR)/.config
include $(TOPDIR)/include/verbose.mk
-export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+export BASH=$(shell which bash)
+
ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
WGET:=$(strip $(subst ",, $(CONFIG_WGET)))