summaryrefslogtreecommitdiff
path: root/openwrt/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-02-24 20:59:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-02-24 20:59:09 +0000
commit1c9302c9a9b94512eaa6f653e66ad1577eed0205 (patch)
tree844da3110ed0a3bb56e4d675eb19d6abeaa9e823 /openwrt/target/Makefile
parentda3879b76c699c78e40254b30f6996ad318abf73 (diff)
downloadmtk-20170518-1c9302c9a9b94512eaa6f653e66ad1577eed0205.zip
mtk-20170518-1c9302c9a9b94512eaa6f653e66ad1577eed0205.tar.gz
mtk-20170518-1c9302c9a9b94512eaa6f653e66ad1577eed0205.tar.bz2
fix make target/linux/package/*-clean
SVN-Revision: 3271
Diffstat (limited to 'openwrt/target/Makefile')
-rw-r--r--openwrt/target/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index e066fa9..24c3403 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -16,6 +16,9 @@ clean: linux-clean utils-clean lzma-clean image_clean
image_clean:
rm -f $(BIN_DIR)/openwrt-*
+linux/package/%:
+ $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
+
%-clean:
@$(TRACE) target/$(patsubst %-clean,%,$@)-clean
$(MAKE) -C $(patsubst %-clean,%,$@) clean
@@ -35,5 +38,4 @@ linux-imagebuilder:
@$(TRACE) target/linux/imagebuilder
$(MAKE) -C linux imagebuilder
-linux/package/%:
- $(MAKE) -C $(TOPDIR)/target/linux $(patsubst linux/%,%,$@)
+