summaryrefslogtreecommitdiff
path: root/openwrt/target/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 00:06:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 00:06:20 +0000
commit35d1297447cc2d8cf4c1037079beafe876094b87 (patch)
treeabaa34bdde876fc22b783aa1c3c445615ac50b75 /openwrt/target/Makefile
parent196076cf2f58b0239a2a9df7d2b09274d23b81ec (diff)
downloadmtk-20170518-35d1297447cc2d8cf4c1037079beafe876094b87.zip
mtk-20170518-35d1297447cc2d8cf4c1037079beafe876094b87.tar.gz
mtk-20170518-35d1297447cc2d8cf4c1037079beafe876094b87.tar.bz2
large build system cleanup. added some stuff to control the verbosity level, but not complete, yet.
SVN-Revision: 2221
Diffstat (limited to 'openwrt/target/Makefile')
-rw-r--r--openwrt/target/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/openwrt/target/Makefile b/openwrt/target/Makefile
index e6156b4..a14749f 100644
--- a/openwrt/target/Makefile
+++ b/openwrt/target/Makefile
@@ -17,15 +17,21 @@ image_clean:
rm -f $(BIN_DIR)/openwrt-*
%-clean:
+ @$(TRACE) target/$(patsubst %-clean,%,$@)/clean
$(MAKE) -C $(patsubst %-clean,%,$@) clean
%-prepare:
+ @$(TRACE) target/$(patsubst %-prepare,%,$@)/prepare
$(MAKE) -C $(patsubst %-prepare,%,$@) prepare
%-compile: %-prepare
+ @$(TRACE) target/$(patsubst %-compile,%,$@)/compile
$(MAKE) -C $(patsubst %-compile,%,$@) compile
%-rebuild:
+ @$(TRACE) target/$(patsubst %-rebuild,%,$@)/rebuild
$(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
%-install: %-compile
+ @$(TRACE) target/$(patsubst %-install,%,$@)/install
$(MAKE) -C $(patsubst %-install,%,$@) install
linux-imagebuilder:
+ @$(TRACE) target/linux/imagebuilder
$(MAKE) -C linux imagebuilder