summaryrefslogtreecommitdiff
path: root/openwrt/target/device
diff options
context:
space:
mode:
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-02-19 07:46:01 +0000
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>2005-02-19 07:46:01 +0000
commit95b6887e9aa27b9788f135635f1d40d9b309f456 (patch)
treefc4b24d257d49bf1fa37f482d183fe7e79ff4457 /openwrt/target/device
parent9d96d4bf9f2339a31bc036dea80866920c9a7c94 (diff)
downloadmtk-20170518-95b6887e9aa27b9788f135635f1d40d9b309f456.zip
mtk-20170518-95b6887e9aa27b9788f135635f1d40d9b309f456.tar.gz
mtk-20170518-95b6887e9aa27b9788f135635f1d40d9b309f456.tar.bz2
sync with buildroot2 from uclibc, add devices, may be used to build other kernel modules for different devices, can be used for other stuff
SVN-Revision: 267
Diffstat (limited to 'openwrt/target/device')
-rw-r--r--openwrt/target/device/Config.in17
-rw-r--r--openwrt/target/device/Makefile.in2
2 files changed, 19 insertions, 0 deletions
diff --git a/openwrt/target/device/Config.in b/openwrt/target/device/Config.in
new file mode 100644
index 0000000..36d056c
--- /dev/null
+++ b/openwrt/target/device/Config.in
@@ -0,0 +1,17 @@
+choice
+ prompt "Device Support"
+ default BR2_TARGET_ALL
+
+config BR2_TARGET_ALL
+ bool "Support for all devices"
+
+config BR2_TARGET_LINKSYS_WRT54G
+ bool "Linksys WRT54G Support"
+
+config BR2_TARGET_LINKSYS_WRT54GS
+ bool "Linksys WRT54GS Support"
+
+config BR2_TARGET_ASUS_WL500G
+ bool "Asus WL-500g Support"
+
+endchoice
diff --git a/openwrt/target/device/Makefile.in b/openwrt/target/device/Makefile.in
new file mode 100644
index 0000000..92d6e76
--- /dev/null
+++ b/openwrt/target/device/Makefile.in
@@ -0,0 +1,2 @@
+-include target/device/*/*/Makefile.in
+-include target/device/all/Makefile.in